summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-07-27 23:53:25 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-07-28 00:32:00 -0400
commit076fd4e791e517c29cf2740d2fa8974a5edfd21d (patch)
treec11d33863f7444b3f18233f3d098627edc7e5314 /gnu/packages/graphics.scm
parentf43458d70a149f78d25aaf0f9362129ecfc1048a (diff)
downloadguix-patches-076fd4e791e517c29cf2740d2fa8974a5edfd21d.tar
guix-patches-076fd4e791e517c29cf2740d2fa8974a5edfd21d.tar.gz
gnu: lib2geom: Fix more tests.
There were still two tests failing on aarch64-linux: 1. rotated-rect-test, 2. ellipse-test. The first one was removed along with the RotatedRect class in latest upstream, while the second one is yet numerical accuracy related. It gets fixed by updating the already existing 'lib2geom-fix-tests' patch. * gnu/packages/graphics.scm (lib2geom): Bump revision to "2", and update commit hash to the latest one available. * gnu/packages/patches/lib2geom-fix-tests.patch: Update patch.
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 2d0e3c1867..d5139b1f04 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -389,8 +389,8 @@ exception-handling library.")
(define-public lib2geom
;; Use the latest master commit, as the 1.0 release suffer build problems.
- (let ((revision "1")
- (commit "42e119d94934a9514c61571cfb6b4af503ece082"))
+ (let ((revision "2")
+ (commit "f98256d2a923955af74b8cff3d456f0df1ee4b59"))
(package
(name "lib2geom")
(version (git-version "1.0" revision commit))
@@ -402,7 +402,7 @@ exception-handling library.")
(file-name (git-file-name name version))
(sha256
(base32
- "195rs0kdbs8w62irha1nwy83bccz04wglmk578qrj1mky7fc4rjv"))
+ "0w6ijaai8i80d0f35c0shgdspqlsdhw3cvz106k1gm7bmnz1wzpq"))
(patches
;; Patches submitted to upstream (see:
;; https://gitlab.com/inkscape/lib2geom/merge_requests/17,