summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-14 00:17:57 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-18 11:40:09 -0500
commit0184192e2483212568b66b87189456caa731f246 (patch)
treeabae3e1fc5f682125e41f0b11fff190db484266a /gnu/packages/graphics.scm
parent87b4c66b72c7e19dc27eacc5979c86ab43425c28 (diff)
downloadguix-patches-0184192e2483212568b66b87189456caa731f246.tar
guix-patches-0184192e2483212568b66b87189456caa731f246.tar.gz
gnu: Move eglexternalplatform and egl-wayland to (gnu packages xorg).
This is to avoid a module cycle between (gnu packages xorg) and (gnu packages graphics). * gnu/packages/graphics.scm (eglexternalplatform, egl-wayland): Move to... * gnu/packages/xorg.scm: ... this file. Remove trailing #t.
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm79
1 files changed, 0 insertions, 79 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 4b4385d3ff..4014af153a 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -119,85 +119,6 @@
#:use-module (guix packages)
#:use-module (guix utils))
-(define-public eglexternalplatform
- (package
- (name "eglexternalplatform")
- (version "1.1")
- (source
- (origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/NVIDIA/eglexternalplatform")
- (commit version)))
- (file-name
- (git-file-name name version))
- (sha256
- (base32 "0lr5s2xa1zn220ghmbsiwgmx77l156wk54c7hybia0xpr9yr2nhb"))))
- (build-system copy-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-pkgconfig
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "eglexternalplatform.pc"
- (("/usr")
- (assoc-ref outputs "out")))
- #t))
- (add-after 'install 'revise
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out")))
- (mkdir-p (string-append out "/include/EGL"))
- (rename-file
- (string-append out "/interface")
- (string-append out "/include/EGL"))
- (mkdir-p (string-append out "/share/pkgconfig"))
- (rename-file
- (string-append out "/eglexternalplatform.pc")
- (string-append out "/share/pkgconfig/eglexternalplatform.pc"))
- (for-each delete-file-recursively
- (list
- (string-append out "/samples")
- (string-append out "/COPYING")
- (string-append out "/README.md"))))
- #t)))))
- (synopsis "EGL External Platform interface")
- (description "EGLExternalPlatform is an specification of the EGL External
-Platform interface for writing EGL platforms and their interactions with modern
-window systems on top of existing low-level EGL platform implementations. This
-keeps window system implementation specifics out of EGL drivers by using
-application-facing EGL functions.")
- (home-page "https://github.com/NVIDIA/eglexternalplatform")
- (license license:expat)))
-
-(define-public egl-wayland
- (package
- (name "egl-wayland")
- (version "1.1.7")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/NVIDIA/egl-wayland")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0xcx1132zwyp4qps074m72ngjlfmysi1jc2d0lp1ml1r9bllkam6"))))
- (build-system meson-build-system)
- (native-inputs
- `(("pkg-config" ,pkg-config)))
- (inputs
- `(("mesa" ,mesa)
- ("wayland" ,wayland)))
- (propagated-inputs
- `(("eglexternalplatform" ,eglexternalplatform)))
- (synopsis "EGLStream-based Wayland external platform")
- (description "EGL-Wayland is an implementation of a EGL External Platform
-library to add client-side Wayland support to EGL on top of EGLDevice and
-EGLStream families of extensions.")
- (home-page "https://github.com/NVIDIA/egl-wayland")
- (license license:expat)))
-
(define-public mmm
(package
(name "mmm")