summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-12-28 14:17:02 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-30 00:03:38 +0100
commit016fcb3f3e94061e1b7c53a14efe7b11f0362da8 (patch)
treea1dcceb13ddeb136656af592349cca46fa0442be /gnu/packages/graphics.scm
parentc1c36f135133794a4d08298bcd20907c4e04bd2b (diff)
downloadguix-patches-016fcb3f3e94061e1b7c53a14efe7b11f0362da8.tar
guix-patches-016fcb3f3e94061e1b7c53a14efe7b11f0362da8.tar.gz
gnu: Add openxr.
* gnu/packages/graphics.scm (openxr): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 3be37d7841..9a0b2d9c9a 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -96,6 +96,7 @@
#:use-module (gnu packages qt)
#:use-module (gnu packages readline)
#:use-module (gnu packages sdl)
+ #:use-module (gnu packages serialization)
#:use-module (gnu packages stb)
#:use-module (gnu packages swig)
#:use-module (gnu packages tbb)
@@ -1919,6 +1920,38 @@ Some feature highlights:
@end itemize\n")
(license license:gpl3+))))
+(define-public openxr
+ (package
+ (name "openxr")
+ (version "1.0.20")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/KhronosGroup/OpenXR-SDK")
+ (commit (string-append "release-" version))))
+ (file-name (git-file-name name version))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Delete bundled jsoncpp.
+ (delete-file-recursively "src/external/jsoncpp")))
+ (sha256
+ (base32 "1jd7jjxlrdi8kjnmn3sad7dgb4h48dbxryfb9snf0kifn47bi20m"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ; there are no tests
+ (native-inputs
+ (list pkg-config python shaderc vulkan-headers))
+ (inputs
+ (list jsoncpp mesa vulkan-loader wayland))
+ (home-page "https://www.khronos.org/openxr/")
+ (synopsis "Generated headers and sources for OpenXR loader")
+ (description "This package contains OpenXR headers, as well as source code
+and build scripts for the OpenXR loader.")
+ ;; Dual licensed. Either license applies.
+ (license (list license:asl2.0 license:expat))))
+
(define-public monado
(package
(name "monado")