summaryrefslogtreecommitdiff
path: root/gnu/packages/graph.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-02-24 19:27:46 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-02-24 19:29:43 +0100
commit7daae3c9d09a4d27586824a1d1af99e7af454d26 (patch)
tree1e0f4df1ded71425a75e5615dda394d9361b7bc2 /gnu/packages/graph.scm
parent02422b3b669e120dcd8b8888893a84909b5b9b87 (diff)
downloadguix-patches-7daae3c9d09a4d27586824a1d1af99e7af454d26.tar
guix-patches-7daae3c9d09a4d27586824a1d1af99e7af454d26.tar.gz
gnu: python-igraph: Update to 0.8.0.
* gnu/packages/graph.scm (python-igraph): Update to 0.8.0. [arguments]: Replace build phase; move check phase after install phase; pass "--use-pkg-config" to avoid rebuilding igraph. [propagated-inputs]: Add python-texttable. [native-inputs]: Add python-pytest.
Diffstat (limited to 'gnu/packages/graph.scm')
-rw-r--r--gnu/packages/graph.scm23
1 files changed, 19 insertions, 4 deletions
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index b372ed919c..63eb36fd7d 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -90,20 +90,35 @@ more.")
(define-public python-igraph
(package (inherit igraph)
(name "python-igraph")
- (version "0.7.1.post6")
+ (version "0.8.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "python-igraph" version))
(sha256
(base32
- "0xp61zz710qlzhmzbfr65d5flvsi8zf2xy78s6rsszh719wl5sm5"))))
+ "13mbrlmnbgbzw6y8ws7wj0a3ly3in8j4l1ngi6yxvgvxxi4bprj7"))))
(build-system python-build-system)
- (arguments '())
+ (arguments
+ '(#:configure-flags
+ (list "--use-pkg-config")
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'build
+ (lambda _
+ (invoke "python" "./setup.py" "build" "--use-pkg-config")))
+ (delete 'check)
+ (add-after 'install 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-v"))))))
(inputs
`(("igraph" ,igraph)))
+ (propagated-inputs
+ `(("python-texttable" ,python-texttable)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)
+ ("python-pytest" ,python-pytest)))
(home-page "http://pypi.python.org/pypi/python-igraph")
(synopsis "Python bindings for the igraph network analysis library")))