summaryrefslogtreecommitdiff
path: root/gnu/packages/graph.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-04-02 15:08:22 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-04-02 15:11:45 +0200
commit6ee48091a459f0fa48debe63d78cc1202d7fa95e (patch)
treecbc67bc123aaeb855b7de676bccdc1fd4bd1becc /gnu/packages/graph.scm
parentba907ae36237f2d9e27c7c43f1ad5b6f75242571 (diff)
downloadguix-patches-6ee48091a459f0fa48debe63d78cc1202d7fa95e.tar
guix-patches-6ee48091a459f0fa48debe63d78cc1202d7fa95e.tar.gz
gnu: Add python-louvain.
* gnu/packages/graph.scm (python-louvain): New variable.
Diffstat (limited to 'gnu/packages/graph.scm')
-rw-r--r--gnu/packages/graph.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index 9dca2be98e..7ed35f1f29 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -245,6 +245,40 @@ subplots, multiple-axes, polar charts, and bubble charts. ")
(define-public python2-plotly
(package-with-python2 python-plotly))
+(define-public python-louvain
+ (package
+ (name "python-louvain")
+ (version "0.6.1")
+ ;; The tarball on Pypi does not include the tests.
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vtraag/louvain-igraph.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0w31537sifkf65sck1iaip5i6d8g64pa3wdwad83d6p9jwkck57k"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-ddt" ,python-ddt)
+ ("python-igraph" ,python-igraph)))
+ (inputs
+ `(("igraph" ,igraph)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/vtraag/louvain-igraph")
+ (synopsis "Algorithm for methods of community detection in large networks")
+ (description
+ "This package provides an implementation of the Louvain algorithm for use
+with igraph. Louvain is a general algorithm for methods of community
+detection in large networks.
+
+This package has been superseded by the @code{leidenalg} package and should
+not be used for new projects.")
+ (license license:gpl3+)))
+
(define-public faiss
(package
(name "faiss")