summaryrefslogtreecommitdiff
path: root/gnu/packages/graph.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-09-14 21:25:17 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-09-14 21:25:17 +0200
commit62881beb4d63a9910b2d640779b7705c120d643f (patch)
tree7fea7b757a8c072817bfe61fc39424d7cc1918be /gnu/packages/graph.scm
parentd60739dff2e2f5eb74173b73a5fd207ef7cd110a (diff)
downloadguix-patches-62881beb4d63a9910b2d640779b7705c120d643f.tar
guix-patches-62881beb4d63a9910b2d640779b7705c120d643f.tar.gz
gnu: r-rgraphviz: Build reproducibly.
Fixes <https://bugs.gnu.org/43398>. * gnu/packages/graph.scm (r-rgraphviz)[arguments]: Add phase "make-reproducible".
Diffstat (limited to 'gnu/packages/graph.scm')
-rw-r--r--gnu/packages/graph.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index a307fee808..ccffccb050 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -134,6 +134,16 @@ more.")
"1calpvzgcz6v7s4x6bf35kj83sga95zjp7x87p5d3qnbv7q2wz5y"))))
(properties `((upstream-name . "Rgraphviz")))
(build-system r-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'make-reproducible
+ (lambda _
+ ;; The replacement value is taken from src/graphviz/builddate.h
+ (substitute* "src/graphviz/configure"
+ (("VERSION_DATE=.*")
+ "VERSION_DATE=20200427.2341\n"))
+ #t)))))
;; FIXME: Rgraphviz bundles the sources of an older variant of
;; graphviz. It does not build with the latest version of graphviz, so
;; we do not add graphviz to the inputs.