summaryrefslogtreecommitdiff
path: root/gnu/packages/graph.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-02-17 15:55:24 -0500
committerLeo Famulari <leo@famulari.name>2018-03-15 10:57:50 -0400
commit5f3616d612273e75334a37c3c94dec490271c7a5 (patch)
treef4963cc326038ba2fdb8aa6a16ed43356466c45b /gnu/packages/graph.scm
parent04953dca414788433f039e1844a6cc1c8f37be5f (diff)
downloadguix-patches-5f3616d612273e75334a37c3c94dec490271c7a5.tar
guix-patches-5f3616d612273e75334a37c3c94dec490271c7a5.tar.gz
gnu: Add python-plotly.
* gnu/packages/graph.scm (python-plotly, python2-plotly): New variables.
Diffstat (limited to 'gnu/packages/graph.scm')
-rw-r--r--gnu/packages/graph.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index 19c9b2269b..6a5e0e753f 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -33,7 +34,10 @@
#:use-module (gnu packages maths)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages python-web)
#:use-module (gnu packages statistics)
+ #:use-module (gnu packages time)
#:use-module (gnu packages xml))
(define-public igraph
@@ -199,3 +203,34 @@ objects from the @code{graph} package.")
represented by horizontal lines, and edges are represented by vertical
lines.")
(license license:expat))))
+
+(define-public python-plotly
+ (package
+ (name "python-plotly")
+ (version "2.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "plotly" version))
+ (sha256
+ (base32
+ "0n18116jz6bl5n9cq23vabv1gcbh1x3yficdnfq55v0z4cwy0zlf"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f)) ; The tests are not distributed in the release
+ (propagated-inputs
+ `(("python-decorator" ,python-decorator)
+ ("python-nbformat" ,python-nbformat)
+ ("python-pytz" ,python-pytz)
+ ("python-requests" ,python-requests)
+ ("python-six" ,python-six)))
+ (home-page "https://plot.ly/python/")
+ (synopsis "Interactive plotting library for Python")
+ (description "Plotly's Python graphing library makes interactive,
+publication-quality graphs online. Examples of how to make line plots, scatter
+plots, area charts, bar charts, error bars, box plots, histograms, heatmaps,
+subplots, multiple-axes, polar charts, and bubble charts. ")
+ (license license:expat)))
+
+(define-public python2-plotly
+ (package-with-python2 python-plotly))