summaryrefslogtreecommitdiff
path: root/gnu/packages/graph.scm
diff options
context:
space:
mode:
authorAlexander Krotov <krotov@iitp.ru>2020-02-11 11:33:13 -0500
committerLeo Famulari <leo@famulari.name>2020-02-11 12:19:27 -0500
commit56973172c9a8744637d6506bdff485cd27ff9791 (patch)
tree355607db936340b177704e278f76278661daea78 /gnu/packages/graph.scm
parentab42204fbc075af65d17205a756168b440c32c63 (diff)
downloadguix-patches-56973172c9a8744637d6506bdff485cd27ff9791.tar
guix-patches-56973172c9a8744637d6506bdff485cd27ff9791.tar.gz
gnu: Add mscgen.
* gnu/packages/graph.scm (mscgen): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/graph.scm')
-rw-r--r--gnu/packages/graph.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index 982def62c6..7b51a4fd90 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2020 Alexander Krotov <krotov@iitp.ru>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -38,6 +39,7 @@
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages cran)
+ #:use-module (gnu packages gd)
#:use-module (gnu packages graphviz)
#:use-module (gnu packages maths)
#:use-module (gnu packages multiprecision)
@@ -501,3 +503,30 @@ isolating planarity obstructions.")
(description "rw computes rank-width and rank-decompositions
of graphs.")
(license license:gpl2+)))
+
+(define-public mscgen
+ (package
+ (name "mscgen")
+ (version "0.20")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.mcternan.me.uk/mscgen/software/mscgen-src-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "08yw3maxhn5fl1lff81gmcrpa4j9aas4mmby1g9w5qcr0np82d1w"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("gd" ,gd)))
+ (home-page "http://www.mcternan.me.uk/mscgen/")
+ (synopsis "Message Sequence Chart Generator")
+ (description "Mscgen is a small program that parses Message Sequence Chart
+descriptions and produces PNG, SVG, EPS or server side image maps (ismaps) as
+the output. Message Sequence Charts (MSCs) are a way of representing entities
+and interactions over some time period and are often used in combination with
+SDL. MSCs are popular in Telecoms to specify how protocols operate although
+MSCs need not be complicated to create or use. Mscgen aims to provide a simple
+text language that is clear to create, edit and understand, which can also be
+transformed into common image formats for display or printing.")
+ (license license:gpl2+)))