summaryrefslogtreecommitdiff
path: root/gnu/packages/graph.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-07-20 11:58:20 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-07-20 12:01:20 +0300
commit541066a02f87e0dbb01387252dda9d0c4eced542 (patch)
tree7cf9928bdd9ba86aeadcecaada9f6e1e78221bd7 /gnu/packages/graph.scm
parentb8e7b284fc09e3222a1a1e11787c17a493f6f1e1 (diff)
downloadguix-patches-541066a02f87e0dbb01387252dda9d0c4eced542.tar
guix-patches-541066a02f87e0dbb01387252dda9d0c4eced542.tar.gz
gnu: python-graph-tool: Sort inputs alphabetically.
* gnu/packages/graph.scm (python-graph-tool)[native-inputs]: Sort alphabetically. [inputs]: Same. [propagated-inputs]: Same.
Diffstat (limited to 'gnu/packages/graph.scm')
-rw-r--r--gnu/packages/graph.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index f178e00312..c9486935ae 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -563,23 +563,23 @@ transformed into common image formats for display or printing.")
"python"))))
"/site-packages/"))))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("gcc-10" ,gcc-10)
- ("ncurses" ,ncurses)))
+ `(("gcc-10" ,gcc-10)
+ ("ncurses" ,ncurses)
+ ("pkg-config" ,pkg-config)))
(inputs
- `(("python" ,python-wrapper)
- ("boost" ,boost)
+ `(("boost" ,boost)
+ ("cairomm" ,cairomm)
+ ("cgal" ,cgal)
("expat" ,expat)
("gmp" ,gmp)
- ("cgal" ,cgal)
- ("sparsehash" ,sparsehash)
("gtk+" ,gtk+)
- ("cairomm" ,cairomm)))
+ ("python" ,python-wrapper)
+ ("sparsehash" ,sparsehash)))
(propagated-inputs
- `(("python-scipy" ,python-scipy)
+ `(("python-matplotlib" ,python-matplotlib)
("python-numpy" ,python-numpy)
("python-pycairo" ,python-pycairo)
- ("python-matplotlib" ,python-matplotlib)))
+ ("python-scipy" ,python-scipy)))
(synopsis "Manipulate and analyze graphs with Python efficiently")
(description "Graph-tool is an efficient Python module for manipulation
and statistical analysis of graphs (a.k.a. networks). Contrary to most other