summaryrefslogtreecommitdiff
path: root/gnu/packages/graph.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-02 22:22:54 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-02 22:23:18 +0100
commit4e35c4290ef64e8fba376f9c3d9754757ebf89da (patch)
treea11ada960ad194c14be49fa4a6f75feff3f22588 /gnu/packages/graph.scm
parent1088744d8748a4ed81accdacab95eb397de0f23b (diff)
downloadguix-patches-4e35c4290ef64e8fba376f9c3d9754757ebf89da.tar
guix-patches-4e35c4290ef64e8fba376f9c3d9754757ebf89da.tar.gz
gnu: Add r-rbiofabric.
* gnu/packages/graph.scm (r-rbiofabric): New variable.
Diffstat (limited to 'gnu/packages/graph.scm')
-rw-r--r--gnu/packages/graph.scm29
1 files changed, 28 insertions, 1 deletions
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index 70df77b5d2..19c9b2269b 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -18,6 +18,7 @@
(define-module (gnu packages graph)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix packages)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
@@ -172,3 +173,29 @@ model.")
"This package interfaces R with the graphviz library for plotting R graph
objects from the @code{graph} package.")
(license license:epl1.0)))
+
+(define-public r-rbiofabric
+ (let ((commit "666c2ae8b0a537c006592d067fac6285f71890ac")
+ (revision "1"))
+ (package
+ (name "r-rbiofabric")
+ (version (string-append "0.3-" revision "." (string-take commit 7)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wjrl/RBioFabric.git")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1yahqrcrqpbcywv73y9rlmyz8apdnp08afialibrr93ch0p06f8z"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-igraph" ,r-igraph)))
+ (home-page "http://www.biofabric.org/")
+ (synopsis "BioFabric network visualization")
+ (description "This package provides an implementation of the function
+@code{bioFabric} for creating scalable network digrams where nodes are
+represented by horizontal lines, and edges are represented by vertical
+lines.")
+ (license license:expat))))