summaryrefslogtreecommitdiff
path: root/gnu/packages/graph.scm
diff options
context:
space:
mode:
authorSarah Morgensen <iskarian@mgsn.dev>2021-07-26 19:56:39 -0700
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-10 11:44:49 -0500
commit1ba19f4bf1d0f429aaa9d6981bb960739fc4dc0a (patch)
tree2ea6557b10fd87a535c4f9a8b5fa3787439ef547 /gnu/packages/graph.scm
parent21566bfd49b69a89263581a9348c81ba12fe42d4 (diff)
downloadguix-patches-1ba19f4bf1d0f429aaa9d6981bb960739fc4dc0a.tar
guix-patches-1ba19f4bf1d0f429aaa9d6981bb960739fc4dc0a.tar.gz
gnu: python-plotly: Remove obsolete phase.
* gnu/packages/graph.scm (python-plotly)[arguments]<#:phases>: Remove 'make-files-writable phase. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/graph.scm')
-rw-r--r--gnu/packages/graph.scm9
1 files changed, 1 insertions, 8 deletions
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index 90f32cc23e..8810617795 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -243,14 +243,7 @@ lines.")
(invoke "pytest" "-x" "plotly/tests/test_io")
;; FIXME: Add optional dependencies and enable their tests.
;; (invoke "pytest" "-x" "plotly/tests/test_optional")
- (invoke "pytest" "_plotly_utils/tests"))
- #t))
- (add-before 'reset-gzip-timestamps 'make-files-writable
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (for-each (lambda (file) (chmod file #o644))
- (find-files out "\\.gz"))
- #t))))))
+ (invoke "pytest" "_plotly_utils/tests")))))))
(native-inputs
(list python-ipywidgets python-pytest python-xarray))
(propagated-inputs