summaryrefslogtreecommitdiff
path: root/gnu/packages/gps.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-03-22 17:03:24 -0400
committerLeo Famulari <leo@famulari.name>2017-03-22 17:04:46 -0400
commite20dafd0a12e2f9098479e3087fb216d510cd058 (patch)
treed2672e7eff4cb36c8e871dc7c263a37892f1f9ff /gnu/packages/gps.scm
parent44cba47e93f3885ab039e7d171bc28c041246fd0 (diff)
downloadguix-patches-e20dafd0a12e2f9098479e3087fb216d510cd058.tar
guix-patches-e20dafd0a12e2f9098479e3087fb216d510cd058.tar.gz
gnu: gpsbabel: Fix a build failure with GCC 5.
* gnu/packages/gps.scm (gpsbabel)[arguments]: Add -fPIC to #:configure-flags.
Diffstat (limited to 'gnu/packages/gps.scm')
-rw-r--r--gnu/packages/gps.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/gps.scm b/gnu/packages/gps.scm
index bc0f3ed115..0a9038b7a4 100644
--- a/gnu/packages/gps.scm
+++ b/gnu/packages/gps.scm
@@ -50,7 +50,10 @@
(arguments
`(#:configure-flags
'("--with-zlib=system"
- "CXXFLAGS=-std=gnu++11")
+ ;; XXX Use -fPIC to work around build problems with Qt, GCC 5, and
+ ;; recent binutils:
+ ;; https://codereview.qt-project.org/#/c/111787/
+ "CXXFLAGS=-std=gnu++11 -fPIC")
#:phases
(modify-phases %standard-phases
(add-before 'configure 'pre-configure