summaryrefslogtreecommitdiff
path: root/gnu/packages/gps.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-10-12 16:50:47 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-12 17:46:23 +0000
commita1eca979fb8da842e73c42f4f53be29b169810f2 (patch)
tree681c7283e412bb8a29c2531c4408b49c3e184764 /gnu/packages/gps.scm
parent48d86a9ec6d8d2e97da2299ea41a03ef4cdaab83 (diff)
parent371aa5777a3805a3886f3feea5f1960fe3fe4219 (diff)
downloadguix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar
guix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen.
Diffstat (limited to 'gnu/packages/gps.scm')
-rw-r--r--gnu/packages/gps.scm17
1 files changed, 7 insertions, 10 deletions
diff --git a/gnu/packages/gps.scm b/gnu/packages/gps.scm
index 19f8a73eef..674f19a8d8 100644
--- a/gnu/packages/gps.scm
+++ b/gnu/packages/gps.scm
@@ -7,7 +7,6 @@
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2021 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
-;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -149,7 +148,7 @@ between two other data points.")
(define-public gama
(package
(name "gama")
- (version "2.14")
+ (version "2.15")
(source
(origin
(method url-fetch)
@@ -157,7 +156,7 @@ between two other data points.")
version ".tar.gz"))
(sha256
(base32
- "04mhbgpqbynnmm8ww4k2yk1w2j66c276dns9xwn8cvrq58kjimln"))
+ "1lsa7k9anxla2r3wxzg2yhxgxlp8xibz56gaxhgf5rd3mzf51flx"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -171,7 +170,7 @@ between two other data points.")
(inputs
`(("expat" ,expat)
("sqlite" ,sqlite)))
- (home-page "https://www.gnu.org/software/gama")
+ (home-page "https://www.gnu.org/software/gama/")
(synopsis "Adjustment of geodetic networks")
(description
"GNU Gama is a program for the adjustment of geodetic networks. It is
@@ -222,14 +221,14 @@ such as elevation, speed, heart rate, power, temperature, and gear shifts.")
(define-public gpsd
(package
(name "gpsd")
- (version "3.23")
+ (version "3.23.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://download-mirror.savannah.gnu.org"
"/releases/gpsd/gpsd-" version ".tar.xz"))
(sha256
- (base32 "1px9im0qfn8k7mnvjcw5myakzd7mad2drwyzji400hpwyswjjr73"))))
+ (base32 "1hd8b09is4gd73lpsdywxxdx11iijikmqgxd0y57pic3yxnlcb6a"))))
(build-system scons-build-system)
(native-inputs
`(("bc" ,bc)
@@ -262,8 +261,7 @@ such as elevation, speed, heart rate, power, temperature, and gear shifts.")
(setenv "TAR" "noop")
(substitute* "SConscript"
(("envs = \\{\\}")
- "envs = os.environ"))
- #t))
+ "envs = os.environ"))))
(add-after 'install 'wrap-python-scripts
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -284,8 +282,7 @@ such as elevation, speed, heart rate, power, temperature, and gear shifts.")
(wrap-program (string-append out "/bin/" script)
`("GUIX_PYTHONPATH" ":" prefix (,pythonpath))))
'("gegps" "gpscat" "gpsfake" "gpsprof"
- "ubxtool" "xgps" "xgpsspeed" "zerk")))
- #t)))))
+ "ubxtool" "xgps" "xgpsspeed" "zerk"))))))))
(synopsis "GPS service daemon")
(description
"@code{gpsd} is a service daemon that monitors one or more GPSes or AIS