summaryrefslogtreecommitdiff
path: root/gnu/packages/gps.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/gps.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/gps.scm')
-rw-r--r--gnu/packages/gps.scm55
1 files changed, 21 insertions, 34 deletions
diff --git a/gnu/packages/gps.scm b/gnu/packages/gps.scm
index dfdb0a5b56..290fa76289 100644
--- a/gnu/packages/gps.scm
+++ b/gnu/packages/gps.scm
@@ -82,14 +82,9 @@
`(#:configure-flags
'("--with-zlib=system")))
(inputs
- `(("expat" ,expat)
- ("libusb" ,libusb)
- ("qtbase" ,qtbase-5)
- ("zlib" ,zlib)))
+ (list expat libusb qtbase-5 zlib))
(native-inputs
- `(("which" ,which)
- ("qttools" ,qttools)
- ("libxml2" ,libxml2))) ;'xmllint' needed for the KML tests
+ (list which qttools libxml2)) ;'xmllint' needed for the KML tests
(home-page "https://www.gpsbabel.org/")
(synopsis "Convert and exchange data with GPS and map programs")
(description
@@ -127,14 +122,9 @@ manipulate maps.")
"\n")))
#t)))))
(inputs
- `(("gtk+" ,gtk+)
- ("libxml2" ,libxml2)
- ("exiv2" ,exiv2)))
+ (list gtk+ libxml2 exiv2))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("docbook-xml" ,docbook-xml)
- ("docbook-xsl" ,docbook-xsl)
- ("libxslt" ,libxslt)))
+ (list pkg-config docbook-xml docbook-xsl libxslt))
(home-page "https://dfandrich.github.io/gpscorrelate/")
(synopsis "GPS photo correlation tool to geo-localize images")
(description
@@ -166,10 +156,9 @@ between two other data points.")
(build-system gnu-build-system)
(arguments '(#:parallel-tests? #f)) ; race condition
(native-inputs
- `(("libxml2" ,libxml2)))
+ (list libxml2))
(inputs
- `(("expat" ,expat)
- ("sqlite" ,sqlite)))
+ (list expat sqlite))
(home-page "https://www.gnu.org/software/gama/")
(synopsis "Adjustment of geodetic networks")
(description
@@ -206,10 +195,9 @@ coordinates as well as partial support for adjustments in global coordinate syst
(string-append "PREFIX="
(assoc-ref outputs "out"))))))))
(inputs
- `(("qtbase" ,qtbase-5)
- ("qtlocation" ,qtlocation)))
+ (list qtbase-5 qtlocation))
(native-inputs
- `(("qttools" ,qttools)))
+ (list qttools))
(home-page "https://www.gpxsee.org")
(synopsis "GPS log file viewer and analyzer")
(description
@@ -232,21 +220,20 @@ such as elevation, speed, heart rate, power, temperature, and gear shifts.")
(base32 "1hd8b09is4gd73lpsdywxxdx11iijikmqgxd0y57pic3yxnlcb6a"))))
(build-system scons-build-system)
(native-inputs
- `(("bc" ,bc)
- ("pkg-config" ,pkg-config)))
+ (list bc pkg-config))
(inputs
- `(("bluez" ,bluez)
- ("dbus" ,dbus)
- ("gtk+" ,gtk+)
- ("libcap" ,libcap)
- ("libusb" ,libusb)
- ("ncurses" ,ncurses)
- ("python" ,python)
- ("python-pycairo" ,python-pycairo)
- ("python-pygobject" ,python-pygobject)
- ("python-pyserial" ,python-pyserial)
- ("python-wrapper" ,python-wrapper)
- ("qtbase" ,qtbase-5)))
+ (list bluez
+ dbus
+ gtk+
+ libcap
+ libusb
+ ncurses
+ python
+ python-pycairo
+ python-pygobject
+ python-pyserial
+ python-wrapper
+ qtbase-5))
(arguments
`(#:scons-flags
(list (string-append "prefix=" %output)