summaryrefslogtreecommitdiff
path: root/gnu/packages/gps.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-15 07:28:47 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-15 07:28:47 +0100
commit6d2ff64584f7fd2835f03148cbef87964a628999 (patch)
treee0dfd116b6de2570a808c5378cb84e02b32228b9 /gnu/packages/gps.scm
parentfacee7941fb4f7430deea329da4705b8858b2c9f (diff)
downloadguix-patches-6d2ff64584f7fd2835f03148cbef87964a628999.tar
guix-patches-6d2ff64584f7fd2835f03148cbef87964a628999.tar.gz
gnu: gpsbabel: Complete licencing information.
* gnu/packages/gps.scm (gpsbabel)[source]: Remove unused files in a snippet. [license]: Add expat.
Diffstat (limited to 'gnu/packages/gps.scm')
-rw-r--r--gnu/packages/gps.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/gps.scm b/gnu/packages/gps.scm
index 2b652c75c7..760d9852d7 100644
--- a/gnu/packages/gps.scm
+++ b/gnu/packages/gps.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -46,7 +47,15 @@
version ".orig.tar.gz"))
(sha256
(base32
- "0xf7wmy2m29g2lm8lqc74yf8rf7sxfl3cfwbk7dpf0yf42pb0b6w"))))
+ "0xf7wmy2m29g2lm8lqc74yf8rf7sxfl3cfwbk7dpf0yf42pb0b6w"))
+ (snippet
+ '(begin
+ ;; Delete files under GPL-compatible licences but never used
+ ;; on GNU systems, rather than bloating the LICENSE field.
+ (with-directory-excursion "gpsbabel"
+ (delete-file "gui/serial_mac.cc") ; Apple MIT
+ (delete-file "mingw/include/ddk/hidsdi.h")) ; public domain
+ #t))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -84,7 +93,8 @@ popular GPS receivers and mapping programs. It contains extensive data
manipulation abilities making it a convenient for server-side processing or as
the back-end for other tools. It does not convert, transfer, send, or
manipulate maps.")
- (license license:gpl2+)))
+ (license (list license:expat ; shapelib/*.[ch]
+ license:gpl2+)))) ; everything else
(define-public gpscorrelate
;; This program is "lightly maintained", so to speak, so we end up taking it