summaryrefslogtreecommitdiff
path: root/gnu/packages/gps.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-08-07 14:06:38 -0400
committerLeo Famulari <leo@famulari.name>2021-07-27 12:34:56 -0400
commit178cbc30d4e4f4a5d718ae220894544709483ef7 (patch)
tree6e9805e2deab06ac1211646c8f28498fe513672f /gnu/packages/gps.scm
parent29883f113087edaf24570fbd7f1113df907f1099 (diff)
downloadguix-patches-178cbc30d4e4f4a5d718ae220894544709483ef7.tar
guix-patches-178cbc30d4e4f4a5d718ae220894544709483ef7.tar.gz
gnu: GPSD: Update to 3.23.
Fixes <https://gitlab.com/gpsd/gpsd/-/issues/144>, "GPSD time will jump back 1024 weeks at after week=2180 (23-October-2021)". See also <http://bugs.gnu.org/49815>. * gnu/packages/gps.scm (gpsd): Update to 3.23. [arguments]: Set TAR=noop in the 'fix-build' phase.
Diffstat (limited to 'gnu/packages/gps.scm')
-rw-r--r--gnu/packages/gps.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/gps.scm b/gnu/packages/gps.scm
index 0eb4362858..8ac16c62aa 100644
--- a/gnu/packages/gps.scm
+++ b/gnu/packages/gps.scm
@@ -222,14 +222,14 @@ such as elevation, speed, heart rate, power, temperature, and gear shifts.")
(define-public gpsd
(package
(name "gpsd")
- (version "3.21")
+ (version "3.23")
(source
(origin
(method url-fetch)
(uri (string-append "https://download-mirror.savannah.gnu.org"
- "/releases/gpsd/gpsd-" version ".tar.gz"))
+ "/releases/gpsd/gpsd-" version ".tar.xz"))
(sha256
- (base32 "14gyqrbrq6jz4y6x59rdpv9d4c3pbn0vh1blq3iwrc6kz0x4ql35"))))
+ (base32 "1px9im0qfn8k7mnvjcw5myakzd7mad2drwyzji400hpwyswjjr73"))))
(build-system scons-build-system)
(native-inputs
`(("bc" ,bc)
@@ -259,7 +259,8 @@ such as elevation, speed, heart rate, power, temperature, and gear shifts.")
(modify-phases %standard-phases
(add-after 'unpack 'fix-build
(lambda* (#:key outputs #:allow-other-keys)
- (substitute* "SConstruct"
+ (setenv "TAR" "noop")
+ (substitute* "SConscript"
(("envs = \\{\\}")
"envs = os.environ"))
#t))