summaryrefslogtreecommitdiff
path: root/gnu/packages/gpodder.scm
diff options
context:
space:
mode:
authorStefan Reichör <stefan@xsteve.at>2021-05-02 17:12:27 +0200
committerLudovic Courtès <ludo@gnu.org>2021-05-05 16:56:44 +0200
commit9661eb86e048d76fd6d64587b28560a6c98f62b8 (patch)
tree78f7118fc3fb4972ddce151282480582ee0c3160 /gnu/packages/gpodder.scm
parent9c3986ffafad113be1cc9061d1f6c56ef1a06647 (diff)
downloadguix-patches-9661eb86e048d76fd6d64587b28560a6c98f62b8.tar
guix-patches-9661eb86e048d76fd6d64587b28560a6c98f62b8.tar.gz
gnu: Add castget.
* gnu/packages/gpodder.scm (castget): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gpodder.scm')
-rw-r--r--gnu/packages/gpodder.scm43
1 files changed, 42 insertions, 1 deletions
diff --git a/gnu/packages/gpodder.scm b/gnu/packages/gpodder.scm
index f185f2e546..677ec3f33e 100644
--- a/gnu/packages/gpodder.scm
+++ b/gnu/packages/gpodder.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019, 2020, 2021 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,20 +22,27 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix packages)
+ #:use-module (guix utils)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system gnu)
#:use-module (guix build-system python)
#:use-module (gnu packages)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages check)
+ #:use-module (gnu packages curl)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages groff)
+ #:use-module (gnu packages mp3)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
- #:use-module (gnu packages video))
+ #:use-module (gnu packages video)
+ #:use-module (gnu packages xml))
(define-public gpodder
(package
@@ -203,3 +211,36 @@ downloading episode status changes.")
provide an easy and reliable way of parsing RSS and Atom-based podcast feeds
in Python.")
(license license:isc)))
+
+(define-public castget
+ (package
+ (name "castget")
+ (version "2.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mlj/castget")
+ (commit (string-append "rel_" (string-replace-substring
+ version "." "_")))))
+ (sha256
+ (base32 "1129x64rw587q3sdpa3lrgs0gni5f0siwbvmfz8ya4zkbhgi2ik7"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)
+ ("ronn-ng" ,ronn-ng)))
+ (inputs `(("curl" ,curl)
+ ("glib" ,glib)
+ ("id3lib" ,id3lib)
+ ("libxml2" ,libxml2)))
+ (synopsis "Command line podcast downloader")
+ (description
+ "castget is a simple, command-line based RSS enclosure downloader. It is
+primarily intended for automatic, unattended downloading of podcasts. It uses
+libcurl for the download process.")
+ (license license:lgpl2.1+)
+ (home-page "https://castget.johndal.com")))