summaryrefslogtreecommitdiff
path: root/gnu/packages/gpodder.scm
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2019-03-21 00:22:01 +0000
committerLudovic Courtès <ludo@gnu.org>2019-03-23 18:15:36 +0100
commit8f2b70775f51fa7367ee6dbaee6aeecfeda5b0ab (patch)
treea75fc1afc47e2390f42b8cf65f2021a0c806820a /gnu/packages/gpodder.scm
parenta9f847adc3f9e996a83bc1a572e9221d4d128def (diff)
downloadguix-patches-8f2b70775f51fa7367ee6dbaee6aeecfeda5b0ab.tar
guix-patches-8f2b70775f51fa7367ee6dbaee6aeecfeda5b0ab.tar.gz
gnu: Add python-podcastparser.
* gnu/packages/podcast.scm (python-podcastparser): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gpodder.scm')
-rw-r--r--gnu/packages/gpodder.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/gpodder.scm b/gnu/packages/gpodder.scm
index c0150402c4..5b872908a5 100644
--- a/gnu/packages/gpodder.scm
+++ b/gnu/packages/gpodder.scm
@@ -21,7 +21,9 @@
#:use-module (guix packages)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system python)
#:use-module (gnu packages)
+ #:use-module (gnu packages check)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages qt))
@@ -54,3 +56,24 @@
@url{https://gpodder.net} APIs. It allows applications to discover, manage
and track podcasts.")
(license license:lgpl2.1+)))
+
+(define-public python-podcastparser
+ (package
+ (name "python-podcastparser")
+ (version "0.6.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "podcastparser" version))
+ (sha256
+ (base32
+ "1ksj1gcmbnm5i43xhpqxbs2mqi6xzawwwkwbh9h6lwa1wxxvv247"))))
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (build-system python-build-system)
+ (home-page "http://gpodder.org/podcastparser")
+ (synopsis "Simplified and fast RSS parser Python library")
+ (description "@code{podcastparser} is a library for the gPodder project to
+provide an easy and reliable way of parsing RSS and Atom-based podcast feeds
+in Python.")
+ (license license:isc)))