summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorPier-Hugues Pellerin <phpellerin@gmail.com>2022-03-27 19:46:29 -0400
committerLeo Famulari <leo@famulari.name>2022-03-27 23:11:18 -0400
commitfff27ded10fec7efaec11a231324681fb8dd0857 (patch)
treef73659726d7ef46b0502225e853897a83ab2ce13 /gnu/packages/golang.scm
parent8731ed8eaecd204a87a804ffa235b85c403d943f (diff)
downloadguix-patches-fff27ded10fec7efaec11a231324681fb8dd0857.tar
guix-patches-fff27ded10fec7efaec11a231324681fb8dd0857.tar.gz
gnu: Go: Update to 1.17.8 [security fixes].
Go 1.17.8 (released 2022-03-03) includes a security fix to the regexp/syntax package[0], as well as bug fixes to the compiler, runtime, the go command, and the crypto/x509 and net packages. See the Go 1.17.8 milestone[1] on the upstream issue tracker for details. [0] CVE-2022-24921 and https://go.dev/issue/51112. [1] https://github.com/golang/go/issues?q=milestone%3AGo1.17.8+label%3ACherryPickApproved * gnu/packages/golang.scm (go-1.17): Update to 1.17.8. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 027221b15c..f3cc1bd6b8 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -626,7 +626,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
(package
(inherit go-1.16)
(name "go")
- (version "1.17.7")
+ (version "1.17.8")
(source
(origin
(method git-fetch)
@@ -636,7 +636,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
(file-name (git-file-name name version))
(sha256
(base32
- "0d0xybn7sy4za3f0s2ffb6yfv6pjabnk4jyvz7dn3hjqhd5lks7m"))))
+ "05qfs17wddxmmi349g9ci12w9fjb5vbss6qpjc4qzgqzznqf0ycy"))))
(outputs '("out" "tests")) ; 'tests' contains distribution tests.
(arguments
`(#:modules ((ice-9 match)