summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-09 12:38:52 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-09 17:19:24 +0300
commitfd2a3046a86a134bb81a8b6a8080908c7a967ed8 (patch)
treec69b46d63965e47928c37d0a35a28dbef0655042 /gnu/packages/golang.scm
parent507da2fef84bf190c811ab6cf7723aec0255b0d9 (diff)
downloadguix-patches-fd2a3046a86a134bb81a8b6a8080908c7a967ed8.tar
guix-patches-fd2a3046a86a134bb81a8b6a8080908c7a967ed8.tar.gz
gnu: Add go-github-com-alcortesm-tgz.
* gnu/packages/golang.scm (go-github-com-alcortesm-tgz): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ab1bcace9e..4d10102688 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5215,3 +5215,42 @@ provides both a client and a server. The client can talk to a standard
ssh-agent that uses UNIX sockets, and one could implement an alternative
ssh-agent process using the sample server. ")
(license license:asl2.0)))
+
+(define-public go-github-com-alcortesm-tgz
+ (let ((commit "9c5fe88206d7765837fed3732a42ef88fc51f1a1")
+ (revision "1"))
+ (package
+ (name "go-github-com-alcortesm-tgz")
+ (version (git-version "0.0.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alcortesm/tgz")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "04dcwnz2c2i4wbq2vx3g2wrdgqpncr2r1h6p1k08rdwk4bq1h8c5"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (substitute* "tgz_test.go"
+ ;; Fix format error
+ (("t.Fatalf\\(\"%s: unexpected error extracting: %s\", err\\)")
+ "t.Fatalf(\"%s: unexpected error extracting: %s\", com, err)"))
+ #t))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/alcortesm/tgz"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'make-git-checkout-writable
+ (lambda* (#:key outputs #:allow-other-keys)
+ (for-each make-file-writable (find-files "."))
+ (for-each make-file-writable (find-files (assoc-ref outputs "out")))
+ #t)))))
+ (home-page "https://github.com/alcortesm/tgz/")
+ (synopsis "Go library to extract tgz files to temporal directories")
+ (description "This package provides a Go library to extract tgz files to
+temporal directories.")
+ (license license:expat))))