summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-08-16 16:44:42 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-08-16 16:44:42 +0200
commitecb7dedaed49b57ad5a6e53f5a0c4f6b4000fa51 (patch)
tree0a51fe551c95feecdd53f742dfefebe9682db3ea /gnu/packages/golang.scm
parente9bec5bd40865b377b1961ef2ee3b498a7c4752f (diff)
downloadguix-patches-ecb7dedaed49b57ad5a6e53f5a0c4f6b4000fa51.tar
guix-patches-ecb7dedaed49b57ad5a6e53f5a0c4f6b4000fa51.tar.gz
gnu: Add go-github-com-kortschak-utter.
* gnu/packages/golang.scm (go-github-com-kortschak-utter): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 24 insertions, 1 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 1ce55875d8..d2f3dc39df 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -23,7 +23,7 @@
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2020 raingloom <raingloom@riseup.net>
;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
-;;; Copyright © 2021 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2021, 2022 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@mgail.com>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
@@ -1142,6 +1142,29 @@ different output targets. Supports colors and text decoration to all popular
terminals.")
(license license:bsd-3)))
+(define-public go-github-com-kortschak-utter
+ (package
+ (name "go-github-com-kortschak-utter")
+ (version "1.5.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kortschak/utter")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "13lg8gzvgjnljf1lz8qsfz3qcmbvrsxp3ip7mp2kscfz07r69dyw"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/kortschak/utter"))
+ (home-page "https://github.com/kortschak/utter")
+ (synopsis "Deep pretty printer")
+ (description
+ "This package implements a deep pretty printer for Go data structures to
+aid data snapshotting.")
+ (license license:isc)))
+
(define-public go-github-com-shadowsocks-go-shadowsocks2
(package
(name "go-github-com-shadowsocks-go-shadowsocks2")