summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-09 16:12:05 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-09 17:19:26 +0300
commitea60163a9d2462581ff584dba55cfa20b6acee49 (patch)
treedc6004ed0ffaf4458c0d7f3120fba99fd95e4ab5 /gnu/packages/golang.scm
parentcff62457cc0a522a70270423015145ec294e7446 (diff)
downloadguix-patches-ea60163a9d2462581ff584dba55cfa20b6acee49.tar
guix-patches-ea60163a9d2462581ff584dba55cfa20b6acee49.tar.gz
gnu: Add go-github-com-zalando-go-keyring.
* gnu/packages/golang.scm (go-github-com-zalando-go-keyring): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3040eefac0..c19b9448ea 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5511,3 +5511,29 @@ and @code{ioutil} packages that is easy to test.")
(description "@code{dbus} is a library that implements native Go client
bindings for the D-Bus message bus system.")
(license license:bsd-2)))
+
+(define-public go-github-com-zalando-go-keyring
+ (package
+ (name "go-github-com-zalando-go-keyring")
+ (version "0.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zalando/go-keyring")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0kj54nkiyccy6m9iy9a53f6412a54xk96j88jaiq35yzdgfa4z3p"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:tests? #f ;XXX: Fix dbus tests
+ #:import-path "github.com/zalando/go-keyring"))
+ (native-inputs
+ `(("go-github-com-godbus-dbus" ,go-github-com-godbus-dbus)
+ ("dbus" ,dbus)))
+ (home-page "https://github.com/zalando/go-keyring/")
+ (synopsis "Library for working with system keyring")
+ (description "@code{go-keyring} is a library for setting, getting and
+deleting secrets from the system keyring.")
+ (license license:expat)))