summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorJoseph LaFreniere <joseph@lafreniere.xyz>2020-07-26 23:55:03 -0500
committerEfraim Flashner <efraim@flashner.co.il>2021-01-03 17:24:27 +0200
commitdafcf2fcc015e66a7924597193f0f012dad1d0d6 (patch)
tree327946983f57ac1f7dab071f070862f50b4f7bb3 /gnu/packages/golang.scm
parent19be547c47c846778698bcf1375687dda1e41fb5 (diff)
downloadguix-patches-dafcf2fcc015e66a7924597193f0f012dad1d0d6.tar
guix-patches-dafcf2fcc015e66a7924597193f0f012dad1d0d6.tar.gz
gnu: Add go-github-com-goccy-yaml.
* gnu/packages/golang.scm (go-github-com-goccy-yaml): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 93e431ff0f..12529439b3 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6484,6 +6484,43 @@ systems can import this package to enable running programs as services without
modifying them.")
(license license:zlib)))
+(define-public go-github-com-goccy-yaml
+ (package
+ (name "go-github-com-goccy-yaml")
+ (version "1.8.0")
+ (home-page "https://github.com/goccy/go-yaml")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1nps58dwkd915mx35h5f0dc05b880b4fdl6dcjxpfmmbzyinvg38"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/goccy/go-yaml"))
+ (propagated-inputs
+ `(("go-github-com-fatih-color" ,go-github-com-fatih-color)
+ ("go-golang-org-x-xerrors" ,go-golang-org-x-xerrors)))
+ (native-inputs
+ `(("go-gopkg-in-go-playground-validator-v9"
+ ,go-gopkg-in-go-playground-validator-v9)))
+ (synopsis "YAML support for the Go language")
+ (description
+ "This package provides features beyond the
+@uref{https://github.com/go-yaml/yaml, defacto YAML library} including:
+
+@itemize
+@item Pretty format for error notifications
+@item Support Scanner or Lexer or Parser as public API
+@item Support Anchor and Alias to Marshaler
+@item Allow referencing elements declared in another file via anchors
+@item Extract value or AST by YAMLPath (YAMLPath is like a JSONPath)
+@end itemize")
+ (license license:expat)))
+
(define-public go-github.com-ulikunitz-xz
(package
(name "go-github.com-ulikunitz-xz")