summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorRouby Pierre-Antoine <pierre-antoine.rouby@inria.fr>2018-05-28 17:03:39 +0200
committerLeo Famulari <leo@famulari.name>2018-05-29 18:39:08 -0400
commitdaed2c5e6a05b181ecc3bed930bd0f6723dec882 (patch)
treea7fea7b61f9be2bdfb2594617c18f851cb92d215 /gnu/packages/golang.scm
parent73fe19ef287fd08971429711511cd82cc657acc5 (diff)
downloadguix-patches-daed2c5e6a05b181ecc3bed930bd0f6723dec882.tar
guix-patches-daed2c5e6a05b181ecc3bed930bd0f6723dec882.tar.gz
gnu: Add go-github-com-google-gofuzz.
* gnu/packages/golang.scm (go-github-com-google-gofuzz): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a23751ca93..ac73016976 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1572,3 +1572,28 @@ with the HTTP protocol definition.")
information about the resource usage and preformance characteristics of running
containers.")
(license license:asl2.0))))
+
+(define-public go-github-com-google-gofuzz
+ (let ((commit "fd52762d25a41827db7ef64c43756fd4b9f7e382")
+ (revision "0"))
+ (package
+ (name "go-github-com-google-gofuzz")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/gofuzz.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1yxmmr73h0lq7ryf3q9a7pcm2x5xrg4d5bxkq8n5pxwxwyq26kw8"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/google/gofuzz"))
+ (home-page "https://github.com/google/gofuzz")
+ (synopsis "Fuzz testing library for Go")
+ (description "Gofuzz is a library for populationg Go objects with random
+values for the purpose of fuzz testing.")
+ (license license:asl2.0))))