summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-01-03 12:25:14 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-01-03 16:04:31 +0200
commitd2c8f1da53b7b9e5b86f87f9acb77ca643a654b0 (patch)
tree9670297ba64f625a61704e70e2bb367e65596b9d /gnu/packages/golang.scm
parent98d93f97696b503f5e0e414295ddaf4013df1d56 (diff)
downloadguix-patches-d2c8f1da53b7b9e5b86f87f9acb77ca643a654b0.tar
guix-patches-d2c8f1da53b7b9e5b86f87f9acb77ca643a654b0.tar.gz
gnu: go-github-com-fatih-color: Remove vendored code.
* gnu/packages/golang.scm (go-github-com-fatih-color)[source]: Add snippet. [propagated-inputs]: Add go-github-com-mattn-go-colorable, go-github-com-mattn-go-isatty.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9074416f7f..adb6bbe488 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6039,10 +6039,17 @@ can be used to build a client and/or a server.")
(file-name (git-file-name name version))
(sha256
(base32
- "1zc0zlilf03h121f9jqq3ar0hfm7706547zysxp2qxbm920pz7h0"))))
+ "1zc0zlilf03h121f9jqq3ar0hfm7706547zysxp2qxbm920pz7h0"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (delete-file-recursively "vendor")))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/fatih/color"))
+ (propagated-inputs
+ (list go-github-com-mattn-go-colorable
+ go-github-com-mattn-go-isatty))
(synopsis "Print colored text in Go")
(description "This package provides an ANSI color package to output
colorized or SGR defined output to the standard output.")