summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-01-03 02:34:30 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2020-02-10 14:57:50 +0100
commitcb2555e28f1ce4d7d70b2b60bed7ad93649772e4 (patch)
tree955160bfd3c317f38e9517ceca1e46fbf88443f7 /gnu/packages/golang.scm
parenteca528cca987ada1942721403794dff32121bfa6 (diff)
downloadguix-patches-cb2555e28f1ce4d7d70b2b60bed7ad93649772e4.tar
guix-patches-cb2555e28f1ce4d7d70b2b60bed7ad93649772e4.tar.gz
gnu: Add go-golang.org-x-sync-errgroup.
* gnu/packages/golang.scm (go-golang.org-x-sync-errgroup): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9102469749..e0bcee9d7c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3077,3 +3077,30 @@ alternative to @code{reflect.DeepEqual} for comparing whether two values
are semantically equal in Go (for writing tests).")
(home-page "https://godoc.org/github.com/google/go-cmp/cmp")
(license license:asl2.0)))
+
+(define-public go-golang.org-x-sync-errgroup
+ (let ((commit "cd5d95a43a6e21273425c7ae415d3df9ea832eeb")
+ (revision "0"))
+ (package
+ (name "go-golang.org-x-sync-errgroup")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/sync")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1nqkyz2y1qvqcma52ijh02s8aiqmkfb95j08f6zcjhbga3ds6hds"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "golang.org/x/sync/errgroup"
+ #:unpack-path "golang.org/x/sync"))
+ (synopsis "Synchronization, error propagation, and Context cancelation
+for groups of goroutines working on subtasks of a common task.")
+ (description "This package provides synchronization, error propagation,
+and Context cancelation for groups of goroutines working on subtasks of a
+common task.")
+ (home-page "https://godoc.org/golang.org/x/sync/errgroup")
+ (license license:bsd-3))))