summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-09 11:01:59 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-09 17:19:23 +0300
commitb3cd7c9bff94d35a41847f3a8660f7290b9f5318 (patch)
tree15a1121e84cbc47d3ee5ae8621580c0e1e35e83c /gnu/packages/golang.scm
parentf18df4f9dea09575b5d40ed6d1461dfface4b7c4 (diff)
downloadguix-patches-b3cd7c9bff94d35a41847f3a8660f7290b9f5318.tar
guix-patches-b3cd7c9bff94d35a41847f3a8660f7290b9f5318.tar.gz
gnu: Add go-github-com-go-git-gcfg.
* gnu/packages/golang.scm (go-github-com-go-git-gcfg): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b991008bb9..9d99aea339 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5112,3 +5112,27 @@ structures and algorithms in Go.")
(description "Package warnings implements error handling with non-fatal
errors (warnings).")
(license license:bsd-2)))
+
+(define-public go-github-com-go-git-gcfg
+ (package
+ (name "go-github-com-go-git-gcfg")
+ (version "1.5.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/go-git/gcfg")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1lb14z4j35pwz2b2rbykkpsq515spwbndb00gwn2xlrzn949xb83"))))
+ (arguments
+ `(#:import-path "github.com/go-git/gcfg"))
+ (native-inputs
+ `(("go-gopkg-in-warnings" ,go-gopkg-in-warnings)
+ ("go-github-com-pkg-errors" ,go-github-com-pkg-errors)))
+ (build-system go-build-system)
+ (home-page "https://github.com/go-git/gcfg/")
+ (synopsis "Gcfg reads INI-style configuration files into Go structs")
+ (description "Gcfg reads INI-style configuration files into Go structs.")
+ (license license:bsd-3)))