summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-09-02 20:57:19 -0400
committerLeo Famulari <leo@famulari.name>2019-09-05 11:09:32 -0400
commita8ad05d40c35e871a23a13a02eea5c0a8c5b70b9 (patch)
tree6e7bf7cae821f7213702bd9b30e7753e7dd7b029 /gnu/packages/golang.scm
parent31885f444f2326f2de304bc5761bdf6cee53b95f (diff)
downloadguix-patches-a8ad05d40c35e871a23a13a02eea5c0a8c5b70b9.tar
guix-patches-a8ad05d40c35e871a23a13a02eea5c0a8c5b70b9.tar.gz
gnu: go-github-com-urfave-cli: Update to 1.21.0.
* gnu/packages/golang.scm (go-github-com-urfave-cli): Update to 1.21.0.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm42
1 files changed, 20 insertions, 22 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 950ba9fb37..6637c9c7f8 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3123,30 +3123,28 @@ as conversion to and from @command{net.Addr}.")
(license license:expat))))
(define-public go-github-com-urfave-cli
- (let ((commit "693af58b4d51b8fcc7f9d89576da170765980581")
- (revision "0"))
- (package
- (name "go-github-com-urfave-cli")
- (version (git-version "1.20.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/urfave/cli.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1krq752xgy658an1696vf4dc2zmp541clwjinhn11394sx2qksh6"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/urfave/cli"))
- (home-page "https://github.com/urfave/cli")
- (synopsis "Simple, fast, and fun package for building command line apps in Go")
- (description "@command{cli} is a simple, fast, and fun package for
+ (package
+ (name "go-github-com-urfave-cli")
+ (version "1.21.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/urfave/cli.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "104jldhxn6d97l5vsbsl0q8hgy1bxrahbr6dbfqrlppva51jmydd"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/urfave/cli"))
+ (home-page "https://github.com/urfave/cli")
+ (synopsis "Simple, fast, and fun package for building command line apps in Go")
+ (description "@command{cli} is a simple, fast, and fun package for
building command line apps in Go. The goal is to enable developers to write
fast and distributable command line applications in an expressive way.")
- (license license:expat))))
+ (license license:expat)))
(define-public go-github-com-whyrusleeping-json-filter
(let ((commit "ff25329a9528f01c5175414f16cc0a6a162a5b8b")