summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-07-16 11:21:56 -0400
committerLeo Famulari <leo@famulari.name>2019-07-29 14:57:02 -0400
commita3b1dc49bb4ab68fce3af1c937545a707ae2d93b (patch)
tree32658ee9ca938e901823feadef76a488ae7118be /gnu/packages/golang.scm
parent5bbf203c3452840e0698d378a4359de58391dc54 (diff)
downloadguix-patches-a3b1dc49bb4ab68fce3af1c937545a707ae2d93b.tar
guix-patches-a3b1dc49bb4ab68fce3af1c937545a707ae2d93b.tar.gz
gnu: Add go-github-com-marten-seemann-qtls.
* gnu/packages/golang.scm (go-github-com-marten-seemann-qtls): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 41d38268d3..302c413880 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3506,3 +3506,29 @@ test.
All locks are implemented with read-write mutexes. To use them like a regular
mutex, simply ignore the RLock/RUnlock functions.")
(license license:unlicense))))
+
+(define-public go-github-com-marten-seemann-qtls
+ (package
+ (name "go-github-com-marten-seemann-qtls")
+ (version "0.2.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/marten-seemann/qtls")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0b9p7bwkm9hfg1mb565q4nw5k7xyks0z2xagz5fp95azy2psbnfg"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/marten-seemann/qtls"
+ ;; The test suite requires networking.
+ #:tests? #f))
+ (propagated-inputs
+ `(("go-golang-org-x-crypto" ,go-golang-org-x-crypto)))
+ (synopsis "TLS 1.3 with QUIC in Go")
+ (description "This package provides @code{qtls}, a QUIC-capable variant of
+the Go standard library's TLS 1.3 implementation.")
+ (home-page "https://github.com/marten-seemann/qtls")
+ (license license:bsd-3)))