summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-10-12 16:50:47 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-12 17:46:23 +0000
commita1eca979fb8da842e73c42f4f53be29b169810f2 (patch)
tree681c7283e412bb8a29c2531c4408b49c3e184764 /gnu/packages/golang.scm
parent48d86a9ec6d8d2e97da2299ea41a03ef4cdaab83 (diff)
parent371aa5777a3805a3886f3feea5f1960fe3fe4219 (diff)
downloadguix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar
guix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e9cf75bd7d..bd9c239b39 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1196,6 +1196,35 @@ standardized in RFC 7539.")
(description "Set is the set collection for the Go language.")
(license license:expat)))
+(define-public go-github-com-dhowett-go-plist
+ (let ((commit "1454fab16a0642638feb0ae98c41f79eccb2a20a")
+ (revision "1"))
+ (package
+ (name "go-github-com-dhowett-go-plist")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/DHowett/go-plist")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "01c9wmhny2rxywcjipq1xa0xw4qm7yd001239grwxcja3b4n45v8"))))
+ (build-system go-build-system)
+ (arguments `(#:import-path "howett.net/plist"))
+ (inputs
+ `(("go-github.com-jessevdk-go-flags" ,go-github.com-jessevdk-go-flags)
+ ("go-github-com-kr-pretty" ,go-github-com-kr-pretty)
+ ("go-gopkg-in-check-v1" ,go-gopkg-in-check-v1)
+ ("go-gopkg-in-yaml-v2" ,go-gopkg-in-yaml-v2)))
+ (home-page "https://github.com/DHowett/go-plist")
+ (synopsis "Apple property list transcoder")
+ (description "This list transcoder supports encoding/decoding property
+lists (Apple XML, Apple Binary, OpenStep, and GNUStep) from/to arbitrary Go
+types.")
+ (license license:giftware))))
+
(define-public go-github-com-blanu-dust
(package
(name "go-github-com-blanu-dust")