summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-07-17 13:24:48 -0400
committerLeo Famulari <leo@famulari.name>2019-07-29 14:57:03 -0400
commit8ffc727e38f7cd2c12879b6c926e936655d0a9b6 (patch)
treeafffd505349ca8bdc2d9eb810e8658f0f4bc427f /gnu/packages/golang.scm
parentea22aa1fafe5d830080ffcacf8aedbe3e3ba1573 (diff)
downloadguix-patches-8ffc727e38f7cd2c12879b6c926e936655d0a9b6.tar
guix-patches-8ffc727e38f7cd2c12879b6c926e936655d0a9b6.tar.gz
gnu: go-github-com-getsentry-raven-go: Update to 0.2.0-0.5c24d51.
* gnu/packages/golang.scm (go-github-com-getsentry-raven-go): Update to 0.2.0-0.5c24d51. (propagated-inputs): Add go-github-com-certifi-gocertifi and go-github-com-pkg-errors.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ca4fe6d822..821b55de25 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -49,6 +49,7 @@
#:use-module (gnu packages lua)
#:use-module (gnu packages mp3)
#:use-module (gnu packages textutils)
+ #:use-module (gnu packages tls)
#:use-module (ice-9 match)
#:use-module (srfi srfi-1))
@@ -1362,12 +1363,11 @@ is similar to Go's standard library @code{json} and @code{xml} package.")
(license license:expat)))
(define-public go-github-com-getsentry-raven-go
- (let ((commit
- "dffeb57df75d6a911f00232155194e43d79d38d7")
+ (let ((commit "5c24d5110e0e198d9ae16f1f3465366085001d92")
(revision "0"))
(package
(name "go-github-com-getsentry-raven-go")
- (version (git-version "0.0.0" revision commit))
+ (version (git-version "0.2.0" revision commit))
(source
(origin
(method git-fetch)
@@ -1377,14 +1377,16 @@ is similar to Go's standard library @code{json} and @code{xml} package.")
(file-name (git-file-name name version))
(sha256
(base32
- "13sb9rvl3369m7fah3ss9g0hwky259snqfn8gmbr0h5zvp651lja"))))
+ "0lvc376sq8r8jhy2v1m6rf1wyld61pvbk0x6j9xpg56ivqy69xs7"))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/getsentry/raven-go"))
- (home-page
- "https://github.com/getsentry/raven-go")
+ (propagated-inputs
+ `(("go-github-com-certifi-gocertifi" ,go-github-com-certifi-gocertifi)
+ ("go-github-com-pkg-errors" ,go-github-com-pkg-errors)))
+ (home-page "https://github.com/getsentry/raven-go")
(synopsis "Sentry client in Go")
- (description "This package is Go client API for the Sentry event/error
+ (description "This package is a Go client API for the Sentry event/error
logging system.")
(license license:bsd-3))))