summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-07-25 13:31:19 -0400
committerLeo Famulari <leo@famulari.name>2019-07-29 14:57:03 -0400
commit8c6be10aba4a737cd2d3ab3b389af815c7d5a9f6 (patch)
treee3dd0101497db551a9f61e34b05be52ca102f62a /gnu/packages/golang.scm
parent2da5275f818f56587fca5527d30919442eb74b4b (diff)
downloadguix-patches-8c6be10aba4a737cd2d3ab3b389af815c7d5a9f6.tar
guix-patches-8c6be10aba4a737cd2d3ab3b389af815c7d5a9f6.tar.gz
gnu: go-github-com-pkg-errors: Update to 0.8.1-0.27936f6.
* gnu/packages/golang.scm (go-github-com-pkg-errors): Update to 0.8.1-0.27936f6.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm40
1 files changed, 21 insertions, 19 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ed9ccd2d14..ca4fe6d822 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3586,23 +3586,25 @@ network protocol.")
(license license:expat)))
(define-public go-github-com-pkg-errors
- (package
- (name "go-github-com-pkg-errors")
- (version "0.8.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/pkg/errors.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0g5qcb4d4fd96midz0zdk8b9kz8xkzwfa8kr1cliqbg8sxsy5vd1"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/pkg/errors"))
- (synopsis "Go error handling primitives")
- (description "This package provides @code{error}, which offers simple
+ (let ((commit "27936f6d90f9c8e1145f11ed52ffffbfdb9e0af7")
+ (revision "0"))
+ (package
+ (name "go-github-com-pkg-errors")
+ (version (git-version "0.8.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pkg/errors.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0yzmgi6g4ak4q8y7w6x0n5cbinlcn8yc3gwgzy4yck00qdn25d6y"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/pkg/errors"))
+ (synopsis "Go error handling primitives")
+ (description "This package provides @code{error}, which offers simple
error handling primitives in Go.")
- (home-page "https://github.com/pkg/errors")
- (license license:bsd-2)))
+ (home-page "https://github.com/pkg/errors")
+ (license license:bsd-2))))