summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorJoseph LaFreniere <joseph@lafreniere.xyz>2020-11-28 22:25:35 -0600
committerLudovic Courtès <ludo@gnu.org>2020-12-23 17:30:14 +0100
commit81c7f13d74530f936d71f8404cdcc71770cf707e (patch)
tree3ee2a7fa09609d2b4b110592886961371cae7f76 /gnu/packages/golang.scm
parentdadabaf358a6e97ba44a20695d64158510d38e1f (diff)
downloadguix-patches-81c7f13d74530f936d71f8404cdcc71770cf707e.tar
guix-patches-81c7f13d74530f936d71f8404cdcc71770cf707e.tar.gz
gnu: Add go-github-com-nwidger-jsoncolor.
* gnu/packages/golang.scm (go-github-com-nwidger-jsoncolor): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 32a897bfbb..0549fbf28d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5342,6 +5342,33 @@ style your output, without you having to deal with all kinds of weird ANSI
escape sequences and color conversions.")
(license license:expat)))
+(define-public go-github-com-nwidger-jsoncolor
+ (package
+ (name "go-github-com-nwidger-jsoncolor")
+ (version "0.3.0")
+ (home-page "https://github.com/nwidger/jsoncolor")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "13rd146pnj7qm70r1333gyd1f61x40nafxlpvdxlci9h7mx8c5p8"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/nwidger/jsoncolor"))
+ (native-inputs
+ `(("go-github-com-fatih-color" ,go-github-com-fatih-color)))
+ (synopsis "Colorized JSON marshalling and encoding")
+ (description
+ "@code{jsoncolor} is a drop-in replacement for @code{encoding/json}'s
+@code{Marshal} and @code{MarshalIndent} functions and @code{Encoder} type
+which produce colorized output using github.com/fatih/color.")
+ (license license:expat)))
+
(define-public go-github-com-olekukonko-tablewriter
(package
(name "go-github-com-olekukonko-tablewriter")