summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-02-22 16:00:20 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-03-06 12:21:42 +0200
commit7722184e6f7db969470b9742434e551ef61ead3a (patch)
tree85c04deb5d99bd1cb70d7077f966510db49a61ea /gnu/packages/golang.scm
parent0c6bf910efd090f0aa0479ba727e5e68655e9b68 (diff)
downloadguix-patches-7722184e6f7db969470b9742434e551ef61ead3a.tar
guix-patches-7722184e6f7db969470b9742434e551ef61ead3a.tar.gz
gnu: Add go-github-com-xdg-go-stringprep.
* gnu/packages/golang.scm (go-github-com-xdg-go-stringprep): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a093728805..e1d9d1fcde 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7867,6 +7867,31 @@ and @code{ioutil} packages that is easy to test.")
@uref{freedesktop.org}.")
(license license:expat)))
+(define-public go-github-com-xdg-go-stringprep
+ (package
+ (name "go-github-com-xdg-go-stringprep")
+ (version "1.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xdg-go/stringprep")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1df0l5n3c520y9filzz83j42wa5c056jcygmfwhjyf1pq8f6jkv9"))))
+ (build-system go-build-system)
+ (arguments '(#:import-path "github.com/xdg-go/stringprep"))
+ (propagated-inputs
+ (list go-golang-org-x-text))
+ (home-page "https://github.com/xdg-go/stringprep")
+ (synopsis "Go implementation of RFC-3454 stringprep and RFC-4013 SASLprep")
+ (description
+ "Package stringprep provides data tables and algorithms for RFC-3454,
+including errata. It also provides a profile for SASLprep as defined in
+RFC-4013.")
+ (license license:asl2.0)))
+
(define-public go-github-com-godbus-dbus
(package
(name "go-github-com-godbus-dbus")