summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorAdam Kandur <rndd@tuta.io>2021-08-29 19:52:55 +0300
committerLudovic Courtès <ludo@gnu.org>2021-09-24 14:11:11 +0200
commit73e44626371446a98f7d3e962f074db702e30fed (patch)
treebf1d4623b5f24aa0425e479d8bd401cb6c21fcce /gnu/packages/golang.scm
parentd055e1f4aa8a31e4ccd94273f910544ecf4c6d16 (diff)
downloadguix-patches-73e44626371446a98f7d3e962f074db702e30fed.tar
guix-patches-73e44626371446a98f7d3e962f074db702e30fed.tar.gz
gnu: Add go-github-com-DHowett-go-plist.
* gnu/packages/golang.scm (go-github-com-DHowett-go-plist): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f02d0aa9df..a96f743f68 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1191,6 +1191,35 @@ standardized in RFC 7539.")
(description "Set is the set collection for the Go language.")
(license license:expat)))
+(define-public go-github-com-dhowett-go-plist
+ (let ((commit "1454fab16a0642638feb0ae98c41f79eccb2a20a")
+ (revision "1"))
+ (package
+ (name "go-github-com-dhowett-go-plist")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/DHowett/go-plist")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "01c9wmhny2rxywcjipq1xa0xw4qm7yd001239grwxcja3b4n45v8"))))
+ (build-system go-build-system)
+ (arguments `(#:import-path "howett.net/plist"))
+ (inputs
+ `(("go-github.com-jessevdk-go-flags" ,go-github.com-jessevdk-go-flags)
+ ("go-github-com-kr-pretty" ,go-github-com-kr-pretty)
+ ("go-gopkg-in-check-v1" ,go-gopkg-in-check-v1)
+ ("go-gopkg-in-yaml-v2" ,go-gopkg-in-yaml-v2)))
+ (home-page "https://github.com/DHowett/go-plist")
+ (synopsis "Apple property list transcoder")
+ (description "This list transcoder supports encoding/decoding property
+lists (Apple XML, Apple Binary, OpenStep, and GNUStep) from/to arbitrary Go
+types.")
+ (license license:giftware))))
+
(define-public go-github-com-blanu-dust
(package
(name "go-github-com-blanu-dust")