summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorJack Hill <jackhill@jackhill.us>2020-12-13 18:07:49 -0500
committerEfraim Flashner <efraim@flashner.co.il>2020-12-17 22:26:31 +0200
commit687ef47768d12d36dd3718be564433fbb5309b0d (patch)
tree81f9c4380ba1cf16f2f80cc8f212145d965b2515 /gnu/packages/golang.scm
parent0435891d6f491088c033b2e711d3b8a654a6f742 (diff)
downloadguix-patches-687ef47768d12d36dd3718be564433fbb5309b0d.tar
guix-patches-687ef47768d12d36dd3718be564433fbb5309b0d.tar.gz
gnu: go-github-com-emicklei-go-restful: Update to 3.4.0.
* gnu/packages/golang.scm (go-github-com-emicklei-go-restful): Update to 3.4.0. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm42
1 files changed, 20 insertions, 22 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f0b43b677e..32a897bfbb 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1240,30 +1240,28 @@ sockets.")
(license license:expat))))
(define-public go-github-com-emicklei-go-restful
- (let ((commit "89ef8af493ab468a45a42bb0d89a06fccdd2fb22")
- (revision "0"))
- (package
- (name "go-github-com-emicklei-go-restful")
- (version (git-version "0.0.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/emicklei/go-restful")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0rrlfcfq80fkxifpih6bq31vavb5mf4530xz51pp9pq1mn2fzjfh"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/emicklei/go-restful"))
- (home-page "https://github.com/emicklei/go-restful")
- (synopsis "Build REST-style web services using Go")
- (description "This package provides @code{go-restful}, which helps
+ (package
+ (name "go-github-com-emicklei-go-restful")
+ (version "3.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emicklei/go-restful")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0m1y5a6xr6hmdj77afrvyh2llkbhn1166lcrgis654shl8zs9qhz"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/emicklei/go-restful"))
+ (home-page "https://github.com/emicklei/go-restful")
+ (synopsis "Build REST-style web services using Go")
+ (description "This package provides @code{go-restful}, which helps
developers to use @code{http} methods explicitly and in a way that's consistent
with the HTTP protocol definition.")
- (license license:expat))))
+ (license license:expat)))
(define-public go-github-com-google-cadvisor
(let ((commit "2ed7198f77395ee9a172878a0a7ab92ab59a2cfd")