summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-01-03 02:34:32 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2020-02-10 14:58:48 +0100
commit639371c6d28465449216cb81b85d7b4b204f96b2 (patch)
tree708417ebeb096a6570cef998668af9e667fb0791 /gnu/packages/golang.scm
parent9d64d1509c67b44f24a24786343754c2c8491741 (diff)
downloadguix-patches-639371c6d28465449216cb81b85d7b4b204f96b2.tar
guix-patches-639371c6d28465449216cb81b85d7b4b204f96b2.tar.gz
gnu: Add gotestsum.
* gnu/packages/golang.scm (gotestsum): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 97acb2a9e9..dbe716d584 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3143,3 +3143,39 @@ common task.")
test when a comparison fails.")
(home-page "https://github.com/gotestyourself/gotest.tools")
(license license:asl2.0)))
+
+(define-public gotestsum
+ (package
+ (name "gotestsum")
+ (version "0.4.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gotestyourself/gotestsum.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0y71qr3ss3hgc8c7nmvpwk946xy1jc5d8whsv6y77wb24ncla7n0"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "gotest.tools/gotestsum"))
+ (native-inputs
+ `(("go-github-com-fatih-color" ,go-github-com-fatih-color)
+ ("go-golang.org-x-sync-errgroup" ,go-golang.org-x-sync-errgroup)
+ ("go-github-com-pkg-errors" ,go-github-com-pkg-errors)
+ ("go-github-com-sirupsen-logrus"
+ ,go-github-com-sirupsen-logrus)
+ ("go-github-com-spf13-pflag" ,go-github-com-spf13-pflag)
+ ("go-github-com-jonboulle-clockwork"
+ ,go-github-com-jonboulle-clockwork)
+ ("go-golang-org-x-crypto" ,go-golang-org-x-crypto)
+ ("go-gotest-tools-assert" ,go-gotest-tools-assert)
+ ("go-github-com-google-go-cmp-cmp"
+ ,go-github-com-google-go-cmp-cmp)))
+ (synopsis "Go test runner with output optimized for humans")
+ (description "This package provides a @code{go test} runner with output
+optimized for humans, JUnit XML for CI integration, and a summary of the
+test results.")
+ (home-page "https://github.com/gotestyourself/gotestsum")
+ (license license:asl2.0)))