summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-09 00:44:38 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-09 17:19:20 +0300
commit633a182112d431151cd77ed2c32490259f74caf4 (patch)
treecd944ad364b6da72a5ca77bba17adfc94d85f800 /gnu/packages/golang.scm
parent36fcbafdb08535c7b1ff63c9acd8a4196f28ab96 (diff)
downloadguix-patches-633a182112d431151cd77ed2c32490259f74caf4.tar
guix-patches-633a182112d431151cd77ed2c32490259f74caf4.tar.gz
gnu: Add go-github-com-muesli-reflow.
* gnu/packages/golang.scm (go-github-com-muesli-reflow): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 6bc214380d..13c07ad732 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4813,3 +4813,27 @@ to jQuery to the Go language.")
(synopsis "HTML sanitizer")
(description "@code{bluemonday} is a HTML sanitizer implemented in Go.")
(license license:bsd-3)))
+
+(define-public go-github-com-muesli-reflow-wordwrap
+ (package
+ (name "go-github-com-muesli-reflow-wordwrap")
+ (version "0.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/muesli/reflow")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "1vhynm2n1az13fn03lp0gi28p9mznq1mblglh8f2rb9y1vkd2dqr"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/muesli/reflow/wordwrap"
+ #:unpack-path "github.com/muesli/reflow"))
+ (native-inputs
+ `(("go-github.com-mattn-go-runewidth" ,go-github.com-mattn-go-runewidth)))
+ (home-page "https://github.com/muesli/reflow/")
+ (synopsis "Collection of methods helping to transform blocks of text")
+ (description "This package provides a collection of ANSI-aware methods and
+io.Writers helping you to transform blocks of text.")
+ (license license:expat)))