summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-09 00:58:24 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-09 17:19:21 +0300
commit55374b806cbebb0ada67249dc5aaa67849350832 (patch)
treec8d61dec8a114ad2075063631266e7006eca156f /gnu/packages/golang.scm
parente465f72fbb73a1f75d7e5573abdb67272bb5ad1a (diff)
downloadguix-patches-55374b806cbebb0ada67249dc5aaa67849350832.tar
guix-patches-55374b806cbebb0ada67249dc5aaa67849350832.tar.gz
gnu: Add go-github-com-muesli-termenv.
* gnu/packages/golang.scm (go-github-com-muesli-termenv): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 89fa696005..5d2d4cd7ea 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4887,3 +4887,33 @@ io.Writers helping you to transform blocks of text.")
(arguments
`(#:import-path "github.com/muesli/reflow/padding"
#:unpack-path "github.com/muesli/reflow"))))
+
+(define-public go-github-com-muesli-termenv
+ (package
+ (name "go-github-com-muesli-termenv")
+ (version "0.7.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/muesli/termenv")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "09fwrdhy7c9qlf70h97f5inh6xvkfq1vi8fwx9q7bwmjjbiykk8m"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/muesli/termenv"))
+ (native-inputs
+ `(("go-github-com-google-goterm" ,go-github-com-google-goterm)
+ ("go-golang-org-colorful" ,go-golang-org-colorful)
+ ("go-github-com-mattn-go-isatty" ,go-github-com-mattn-go-isatty)
+ ("go-github.com-mattn-go-runewidth" ,go-github.com-mattn-go-runewidth)))
+ (home-page "https://github.com/muesli/termenv/")
+ (synopsis "Advanced styling options on the terminal")
+ (description "termenv lets you safely use advanced styling options on the
+terminal. It gathers information about the terminal environment in terms of
+its ANSI and color support and offers you convenient methods to colorize and
+style your output, without you having to deal with all kinds of weird ANSI
+escape sequences and color conversions.")
+ (license license:expat)))