summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorAlex Griffin <a@ajgrf.com>2019-04-20 14:01:17 -0500
committerLeo Famulari <leo@famulari.name>2019-05-27 14:26:46 -0400
commit521d736ae97ef34f4e6136c7175a99c680c5ac95 (patch)
tree33f89a588d2bdf5b4a45bdf061863828ce716640 /gnu/packages/golang.scm
parent8d1647b2286337d8c94f127ff2a0258a1550fd4d (diff)
downloadguix-patches-521d736ae97ef34f4e6136c7175a99c680c5ac95.tar
guix-patches-521d736ae97ef34f4e6136c7175a99c680c5ac95.tar.gz
gnu: go@1.4: Update to 1.4-bootstrap-20171003.
* gnu/packages/golang.scm (go-1.4): Use the bootstrap branch that is still supported upstream. [version]: Update to 1.4-bootstrap-20171003. [arguments]: Remove obsolete fix for timezone test which is now included upstream. Don't manually disable cgo because it is disabled by default. Manually enable test suite because future releases will disable tests by default. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm20
1 files changed, 7 insertions, 13 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ed0a78c6bd..611c848bd5 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright @ 2018, 2019 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;; Copyright @ 2019 Giovanni Biscuolo <g@xelera.eu>
+;;; Copyright @ 2019 Alex Griffin <a@ajgrf.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -61,14 +62,16 @@
(define-public go-1.4
(package
(name "go")
- (version "1.4.3")
+ ;; The C-langauge bootstrap of Go:
+ ;; https://golang.org/doc/install/source#go14
+ (version "1.4-bootstrap-20171003")
(source (origin
(method url-fetch)
(uri (string-append "https://storage.googleapis.com/golang/"
- name version ".src.tar.gz"))
+ name version ".tar.gz"))
(sha256
(base32
- "0na9yqilzpvq0bjndbibfp07wr796gf252y471cip10bbdqgqiwr"))))
+ "0liybk5z00hizsb5ypkbhqcawnwwa6mkwgvjjg4y3jm3ndg5pzzl"))))
(build-system gnu-build-system)
(outputs '("out"
"doc"
@@ -135,13 +138,6 @@
("os/os_test.go" "(.+)(TestHostname.+)")
("time/format_test.go" "(.+)(TestParseInSydney.+)")
- ;; Tzdata 2016g changed the name of the time zone used in this
- ;; test, and the patch for Go 1.7 does not work for 1.4.3:
- ;; https://github.com/golang/go/issues/17545
- ;; https://github.com/golang/go/issues/17276
- ("time/time_test.go" "(.+)(TestLoadFixed.+)")
- ("time/format_test.go" "(.+)(TestParseInLocation.+)")
-
("os/exec/exec_test.go" "(.+)(TestEcho.+)")
("os/exec/exec_test.go" "(.+)(TestCommandRelativeName.+)")
("os/exec/exec_test.go" "(.+)(TestCatStdin.+)")
@@ -168,9 +164,7 @@
(setenv "GOOS" "linux")
(setenv "GOROOT" (dirname (getcwd)))
(setenv "GOROOT_FINAL" output)
- ;; Go 1.4's cgo will not work with binutils >= 2.27:
- ;; https://github.com/golang/go/issues/16906
- (setenv "CGO_ENABLED" "0")
+ (setenv "GO14TESTS" "1")
(invoke "sh" "all.bash"))))
(replace 'install