summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorLéo Le Bouter <lle-bout@zaclys.net>2021-03-11 10:53:00 +0100
committerLéo Le Bouter <lle-bout@zaclys.net>2021-03-11 11:02:23 +0100
commit500189b4d2f1e3a2d4ee8ab73d889e3d8ac70632 (patch)
treec5d89c9816f148d7f079024e782aa1bea916d3af /gnu/packages/golang.scm
parentfd2751f89f04669227bbd71243bb100e3742a3fd (diff)
downloadguix-patches-500189b4d2f1e3a2d4ee8ab73d889e3d8ac70632.tar
guix-patches-500189b4d2f1e3a2d4ee8ab73d889e3d8ac70632.tar.gz
gnu: go: Update to 1.14.15 [security fixes].
This update will cause more than 300 packages to be rebuilt but due to how Go works we can't graft to fix the issue since we actually need to rebuild dependents so they include a newer version of the Go standard library. Considering the CVEs that this fixes are in great part in the Go standard library we can only proceed and push directly to master. * gnu/packages/golang.scm (go): Update to 1.14.15. [arguments]: Remove more cgo-related failing tests.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index dd50da1c8e..849227d693 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -235,7 +235,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
(package
(inherit go-1.4)
(name "go")
- (version "1.14.10")
+ (version "1.14.15")
(source
(origin
(method git-fetch)
@@ -245,7 +245,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
(file-name (git-file-name name version))
(sha256
(base32
- "0h1nmqzjc0xxpn6n2hjq7692gdqkznagzdmiq9490yzkrrii2lgk"))))
+ "1crh90qkvhlx23hwsi4wxy3l3h8973lr18135y6h1nnzzwr3n3ps"))))
(arguments
(substitute-keyword-arguments (package-arguments go-1.4)
((#:system system)
@@ -285,7 +285,10 @@ in the style of communicating sequential processes (@dfn{CSP}).")
"cmd/go/testdata/script/cover_cgo.txt"
"cmd/go/testdata/script/cover_cgo_xtest.txt"
"cmd/go/testdata/script/cover_cgo_extra_test.txt"
- "cmd/go/testdata/script/cover_cgo_extra_file.txt"))
+ "cmd/go/testdata/script/cover_cgo_extra_file.txt"
+ "cmd/go/testdata/script/cgo_path_space.txt"
+ "cmd/go/testdata/script/ldflag.txt"
+ "cmd/go/testdata/script/cgo_path.txt"))
(for-each make-file-writable (find-files "."))