summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2020-07-13 04:21:11 +0200
committerJulien Lepiller <julien@lepiller.eu>2020-10-14 00:51:18 +0200
commit4a28246d3080598d2f5b0a249607fc0ccbf81e83 (patch)
tree3d6027e77c34c6ee02ad2b238afe1bab2022e4e2 /gnu/packages/golang.scm
parent6e085d6f17e831e88a35c275892bde32fdb11986 (diff)
downloadguix-patches-4a28246d3080598d2f5b0a249607fc0ccbf81e83.tar
guix-patches-4a28246d3080598d2f5b0a249607fc0ccbf81e83.tar.gz
gnu: Add go-github-com-cheggaaa-pb.
* gnu/packages/golang.scm (go-github-com-cheggaaa-pb): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c908a52453..f76e49220a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5763,3 +5763,33 @@ error messages.")
(description "Phony is a very minimal actor model library for Go,
inspired by the causal messaging system in the Pony programming language.")
(license license:expat))))
+
+(define-public go-github-com-cheggaaa-pb
+ (package
+ (name "go-github-com-cheggaaa-pb")
+ (version "3.0.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cheggaaa/pb/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0xhsv9yf3fz918ay6w0d87jnb3hk9vxvi16jk172kqq26x7jixd0"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/cheggaaa/pb/"))
+ (propagated-inputs
+ `(("go-github-com-fatih-color" ,go-github-com-fatih-color)
+ ("go-github-com-mattn-go-colorable" ,go-github-com-mattn-go-colorable)
+ ("go-github.com-mattn-go-runewidth" ,go-github.com-mattn-go-runewidth)
+ ("go-golang-org-x-sys" ,go-golang-org-x-sys)))
+ (native-inputs
+ `(("go-github-com-mattn-go-isatty" ,go-github-com-mattn-go-isatty)))
+ (home-page "https://github.com/cheggaaa/pb/")
+ (synopsis "Console progress bar for Go")
+ (description "This package is a Go library that draws progress bars on
+the terminal.")
+ (license license:bsd-3)))