summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorJoseph LaFreniere <joseph@lafreniere.xyz>2020-07-26 20:37:37 -0500
committerEfraim Flashner <efraim@flashner.co.il>2021-01-03 17:24:26 +0200
commit398f5b49a4890e2a3cfd6014bcd6c9975232da88 (patch)
tree5fb3dad5357b777443c277e5198f79b33a14b5a8 /gnu/packages/golang.scm
parent6e95e7d25f27fac4a5d017f6c2ea3e2d16c2f8c4 (diff)
downloadguix-patches-398f5b49a4890e2a3cfd6014bcd6c9975232da88.tar
guix-patches-398f5b49a4890e2a3cfd6014bcd6c9975232da88.tar.gz
gnu: Add go-github-com-go-playground-locales.
* gnu/packages/golang.scm (go-github-com-go-playground-locales): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index bbd18cf932..32b89fab33 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -537,6 +537,40 @@ way of specifying command line options.")
(home-page "https://github.com/jessevdk/go-flags")
(license license:bsd-3)))
+(define-public go-github-com-go-playground-locales
+ (package
+ (name "go-github-com-go-playground-locales")
+ (version "0.13.0")
+ (home-page "https://github.com/go-playground/locales")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0qydcpkvss3mf8mk3xzg6a34n8i69aydrigcl2apifrkx72jw7pf"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/go-playground/locales"))
+ (synopsis "Set of locales generated from the CLDR Unicode Project")
+ (description
+ "This package provides a set of locales generated from the
+@uref{http://cldr.unicode.org/, Unicode CLDR Project} which can be used
+independently or within an internalization (i18n) package. Its currently
+implemented features include
+
+@itemize
+@item Rules generated from the CLDR data, v31.0.3
+@item Contains Cardinal, Ordinal and Range Plural Rules
+@item Contains Month, Weekday and Timezone translations built in
+@item Contains Date & Time formatting functions
+@item Contains Number, Currency, Accounting and Percent formatting functions
+@item Supports the \"Gregorian\" calendar only
+@end itemize")
+ (license license:expat)))
+
(define-public go-github-com-aws-sdk
(package
(name "go-github-com-aws-sdk")