summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-07-16 10:26:44 -0400
committerLeo Famulari <leo@famulari.name>2019-07-29 14:57:02 -0400
commit33b67efeb4a2eb25d15f6b51419818461596a211 (patch)
treee65aa7198a9ca1461b1de9ff981ad296394d4bfd /gnu/packages/golang.scm
parentcb3625bcd77fe84e24ad5ad99dab7a7134227add (diff)
downloadguix-patches-33b67efeb4a2eb25d15f6b51419818461596a211.tar
guix-patches-33b67efeb4a2eb25d15f6b51419818461596a211.tar.gz
gnu: Add go-golang-org-x-tools.
* gnu/packages/golang.scm (go-golang-org-x-tools): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 2fd2154523..077aff2a21 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -769,6 +769,37 @@ expressing configuration which is easy for both humans and machines to read.")
(home-page "https://github.com/hashicorp/hcl")
(license license:mpl2.0))))
+(define-public go-golang-org-x-tools
+ (let ((commit "8b927904ee0dec805c89aaf9172f4459296ed6e8")
+ (revision "0"))
+ (package
+ (name "go-golang-org-x-tools")
+ (version (git-version "0.1.3" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/tools")
+ (commit commit)))
+ (file-name (string-append "go.googlesource.com-tools-"
+ version "-checkout"))
+ (sha256
+ (base32
+ "0iinb70xhcjsddgi42ia1n745lx2ibnjdm6m2v666qrk3876vpck"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "golang.org/x/tools"
+ ;; Source-only package
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ ;; Source-only package
+ (delete 'build))))
+ (synopsis "Tools that support the Go programming language")
+ (description "This package provides miscellaneous tools that support the
+Go programming language.")
+ (home-page "https://go.googlesource.com/tools/")
+ (license license:bsd-3))))
+
(define-public go-golang-org-x-crypto-bcrypt
(let ((commit "b7391e95e576cacdcdd422573063bc057239113d")
(revision "3"))