summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorMartin Becze <mjbecze@riseup.net>2020-11-30 14:24:03 -0600
committerChristopher Baines <mail@cbaines.net>2020-12-08 08:37:44 +0000
commit33504d4d70edd8c4a1c40cc03ea7993f926cb7d8 (patch)
tree77f520c79d6cf8abd11a7f75de17d5d75aa2071a /gnu/packages/golang.scm
parent836428c793b6914665067f589aad2b7c4ef54dbf (diff)
downloadguix-patches-33504d4d70edd8c4a1c40cc03ea7993f926cb7d8.tar
guix-patches-33504d4d70edd8c4a1c40cc03ea7993f926cb7d8.tar.gz
gnu: Add go-github-com-felixge-httpsnoop.
* gnu/packages/golang.scm (go-github-com-felixge-httpsnoop): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e03663e560..b0502d8f6f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -22,6 +22,7 @@
;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2020 raingloom <raingloom@riseup.net>
+;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1522,6 +1523,31 @@ GNU extensions} to the POSIX recommendations for command-line options.")
all types of configuration needs and formats.")
(license license:expat)))
+(define-public go-github-com-felixge-httpsnoop
+ (package
+ (name "go-github-com-felixge-httpsnoop")
+ (version "1.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/felixge/httpsnoop")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ncd8lar5zxiwjhsp315s4hsl4bhnm271h49jhyxc66r5yffgmac"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/felixge/httpsnoop"))
+ (home-page "https://github.com/felixge/httpsnoop/")
+ (synopsis "Capture http related metrics")
+ (description
+ "Httpsnoop provides an easy way to capture http related
+metrics (i.e. response time, bytes written, and http status code) from your
+application's http.Handlers.")
+ (license license:expat)))
+
(define-public go-github-com-fsnotify-fsnotify
(package
(name "go-github-com-fsnotify-fsnotify")