summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <ambrevar@gmail.com>2018-06-22 17:39:57 +0200
committerPierre Neidhardt <ambrevar@gmail.com>2018-07-22 21:26:20 +0200
commit32cb1af632b4b3b801a3493a05af4a65f9303207 (patch)
treeef010abddce4331170dd847fa789e03d3f9362f5 /gnu/packages/golang.scm
parent7601b4e4fe93130562475efc67a641c2f3b8ccc8 (diff)
downloadguix-patches-32cb1af632b4b3b801a3493a05af4a65f9303207.tar
guix-patches-32cb1af632b4b3b801a3493a05af4a65f9303207.tar.gz
gnu: Add go-github-com-mgutz-ansi.
* gnu/packages/golang.scm (go-github-com-mgutz-ansi): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index aabde78d62..26fdc9d2b8 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2030,3 +2030,34 @@ terminal.")
(description "This package provides @code{colorable}, a module that
makes it possible to handle ANSI color escapes on Windows.")
(license license:expat))))
+
+(define-public go-github-com-mgutz-ansi
+ (let ((commit "9520e82c474b0a04dd04f8a40959027271bab992")
+ (revision "0"))
+ (package
+ (name "go-github-com-mgutz-ansi")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/mgutz/ansi")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00bz22314j26736w1f0q4jy9d9dfaml17vn890n5zqy3cmvmww1j"))))
+ (build-system go-build-system)
+ (native-inputs
+ `(("go-github-com-mattn-go-isatty"
+ ,go-github-com-mattn-go-isatty)
+ ("go-github-com-mattn-go-colorable"
+ ,go-github-com-mattn-go-colorable)))
+ (arguments
+ '(#:import-path "github.com/mgutz/ansi"))
+ (home-page "https://github.com/mgutz/ansi")
+ (synopsis "Small, fast library to create ANSI colored strings and codes")
+ (description "This package provides @code{ansi}, a Go module that can
+generate ANSI colored strings.")
+ (license license:expat))))