summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-01-03 01:26:29 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2020-01-03 01:27:23 +0100
commit28cdd818faf78d24841a965cf05a85b96fbd7ed5 (patch)
tree244ebd276f6f5c38dac1d79fd341934cc6108542 /gnu/packages/golang.scm
parent2f907eea003a22a66c10416d99f914887d629321 (diff)
downloadguix-patches-28cdd818faf78d24841a965cf05a85b96fbd7ed5.tar
guix-patches-28cdd818faf78d24841a965cf05a85b96fbd7ed5.tar.gz
gnu: go-github-com-spf13-pflag: Update to 1.0.5.
* gnu/packages/golang.scm (go-github-com-spf13-pflag): Update to 1.0.5.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm44
1 files changed, 21 insertions, 23 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d66527c660..f94251abaf 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1128,33 +1128,31 @@ incoming requests with their respective handler.")
(license license:asl2.0))))
(define-public go-github-com-spf13-pflag
- (let ((commit "4f9190456aed1c2113ca51ea9b89219747458dc1")
- (revision "0"))
- (package
- (name "go-github-com-spf13-pflag")
- (version (git-version "0.0.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/spf13/pflag.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "12vrlcsbwjqlfc49rwky45mbcj74c0kb6z54354pzas6fwzyi1kc"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/spf13/pflag"))
- (home-page "https://github.com/spf13/pflag")
- (synopsis "Replacement for Go's @code{flag} package")
- (description
- "Pflag is library to replace Go's @code{flag} package. It implements
+ (package
+ (name "go-github-com-spf13-pflag")
+ (version "1.0.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/spf13/pflag.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0gpmacngd0gpslnbkzi263f5ishigzgh6pbdv9hp092rnjl4nd31"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/spf13/pflag"))
+ (home-page "https://github.com/spf13/pflag")
+ (synopsis "Replacement for Go's @code{flag} package")
+ (description
+ "Pflag is library to replace Go's @code{flag} package. It implements
POSIX/GNU-style command-line options with double hyphens. It is is compatible
with the
@uref{https://www.gnu.org/software/libc/manual/html_node/Argument-Syntax.html,
GNU extensions} to the POSIX recommendations for command-line options.")
- (license license:bsd-3))))
+ (license license:bsd-3)))
(define-public go-github-com-sirupsen-logrus
(package