summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSarah Morgensen <iskarian@mgsn.dev>2021-07-26 19:56:38 -0700
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-10 11:44:49 -0500
commit21566bfd49b69a89263581a9348c81ba12fe42d4 (patch)
treed25ed088eea46dc3c83dbe34b11016d86fa16b4b /gnu/packages/golang.scm
parent8347c49e56b5ec1198d74a9340f16309e32b248b (diff)
downloadguix-patches-21566bfd49b69a89263581a9348c81ba12fe42d4.tar
guix-patches-21566bfd49b69a89263581a9348c81ba12fe42d4.tar.gz
gnu: go-github-com-gdamore-tcell: Remove obsolete phase.
* gnu/packages/golang.scm (go-github-com-gdamore-tcell)[arguments] <#:phases>: Remove 'make-files-writable phase. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm12
1 files changed, 1 insertions, 11 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 7e135009a0..46b599a6a7 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5552,17 +5552,7 @@ non-UTF-friendly sources.")
"0il2nnxp2cqiy73m49215dnf9in3vd25ji8qxbmq87c5qy7i1q9d"))))
(build-system go-build-system)
(arguments
- `(#:import-path "github.com/gdamore/tcell"
- #:phases
- (modify-phases %standard-phases
- (add-before 'reset-gzip-timestamps 'make-files-writable
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Make sure .gz files are writable so that the
- ;; 'reset-gzip-timestamps' phase can do its work.
- (let ((out (assoc-ref outputs "out")))
- (for-each make-file-writable
- (find-files out "\\.gz$"))
- #t))))))
+ `(#:import-path "github.com/gdamore/tcell"))
(inputs
(list go-github.com-mattn-go-runewidth go-golang-org-colorful
go-golang-org-x-text go-github-com-gdamore-encoding))