summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-08 23:24:33 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-09 17:19:18 +0300
commit1d47f7526628c0fbfa6079ebcb3cd8c82c5304ea (patch)
tree731a1d6bbe147e42fba6e7a0855196105fb95cd1 /gnu/packages/golang.scm
parentbdb5a10880faeb2802108d762b4044c440df98c4 (diff)
downloadguix-patches-1d47f7526628c0fbfa6079ebcb3cd8c82c5304ea.tar
guix-patches-1d47f7526628c0fbfa6079ebcb3cd8c82c5304ea.tar.gz
gnu: Add go-github-com-dlclark-regexp2.
* gnu/packages/golang.scm (go-github-com-dlclark-regexp2): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index da5d584ff1..ee501e8d0b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4496,3 +4496,24 @@ template functions.")
(description "@code{doublestar} is a Go implementation of path pattern
matching and globbing with support for \"doublestar\" patterns.")
(license license:expat)))
+
+(define-public go-github-com-dlclark-regexp2
+ (package
+ (name "go-github-com-dlclark-regexp2")
+ (version "1.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dlclark/regexp2")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "011l1prsywvhhi0yc7qmpsca1cwavmawyyld5kjzi0ff9ghvj4ng"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/dlclark/regexp2"))
+ (home-page "https://github.com/dlclark/regexp2/")
+ (synopsis "Full featured regular expressions for Go")
+ (description "Regexp2 is a feature-rich RegExp engine for Go.")
+ (license license:expat)))