summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorJoseph LaFreniere <joseph@lafreniere.xyz>2020-11-08 22:00:53 -0600
committerEfraim Flashner <efraim@flashner.co.il>2021-01-03 17:24:28 +0200
commit10a8bf02bcc3b41cec13ed1badbbe33dcf53b70d (patch)
tree2c9bf769fcf854b5115274afa5cf99b795479def /gnu/packages/golang.scm
parent289385f0de53cda4583b88ed21c5e3d32af478fd (diff)
downloadguix-patches-10a8bf02bcc3b41cec13ed1badbbe33dcf53b70d.tar
guix-patches-10a8bf02bcc3b41cec13ed1badbbe33dcf53b70d.tar.gz
gnu: Add go-github-com-urfave-cli-v2.
* gnu/packages/golang.scm (go-github-com-urfave-cli-v2): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 414d671a75..f9a32d11c0 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3600,6 +3600,23 @@ building command line apps in Go. The goal is to enable developers to write
fast and distributable command line applications in an expressive way.")
(license license:expat)))
+(define-public go-github-com-urfave-cli-v2
+ (package
+ (inherit go-github-com-urfave-cli)
+ (name "go-github-com-urfave-cli-v2")
+ (version "2.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/urfave/cli")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "08pvn7gyfznni72xrxfh2x6xxa8ykr7l1ka278js8g8qkh71bj8l"))))
+ (arguments
+ '(#:import-path "github.com/urfave/cli/v2"))))
+
(define-public go-github-com-go-md2man
(package
(name "go-github-com-go-md2man")